Ad Inserter < 2.7.27 - Admin+ PHP Object Injection
Priority HIGH 67Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Ad Inserter WordPress plugin before 2.7.27 unserializes user input provided via the settings, which could allow high privilege users such as admin to perform PHP Object Injection when a suitable gadget is present
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.16903 97th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Ad Inserter (Unknown): 2.7.27
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Ad Inserter | before 2.7.27 | 2.7.27 | Patch available | CNA |
- Ad Inserter VendorUnknown Affected before 2.7.27 Fixed in 2.7.27 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ad_inserter_project:ad_inserter:*:*:*:*:*:wordpress:*:* | before 2.7.27 | Vulnerable | Ad Inserter Project |
- cpe:2.3:a:ad_inserter_project:ad_inserter:*:*:*:*:*:wordpress:*:* Versions before 2.7.27 Vulnerable ·Ad Inserter Project
Remediation
- Fix · CNA Ad Inserter (Unknown) Fixed in 2.7.27
Timeline
- 2026-10-02 Threatist record created from CVE-2023-1549
- 2026-10-03 Alias added: GHSA-v9wx-wp77-q49m
References
More Ad Inserter Project Ad Inserter vulnerabilities
- TI-2019-11428 The ad-inserter plugin before 2.4.22 for WordPress has remote code execution. CVSS 3.0HIGH 8.8
- TI-2023-04301 Ad Inserter <= 2.7.30 - Unauthenticated Sensitive Information Exposure via ai-debug-processing-fe CVSS 3.1HIGH 7.5
- TI-2015-07874 The ad-inserter plugin before 1.5.3 for WordPress has CSRF with resultant XSS via… CVSS 3.1HIGH 8.8
- TI-2019-11427 The ad-inserter plugin before 2.4.20 for WordPress has path traversal. CVSS 3.1HIGH 7.5
- TI-2022-00805 Ad Inserter < 2.7.12 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2022-00220 Ad Inserter < 2.7.10 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
Sources
- CVE-2023-1549 · CVE Program
- CVE-2023-1549 · NVD
- FIRST EPSS
- GHSA-v9wx-wp77-q49m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences