The Job Postings WordPress plugin before 2.7.11 does not sanitise and escape some of its settings, which could allow high privilege users such as contributor to perform Stored Cross-Site Scripting attacks even when the u…
CVSS 3.1MEDIUM 5.9·Network·High privileges·User interaction·EPSS 0.00323·Published 2025-03-25·Fixed in 2.7.11CWE-79
The Jobs for WordPress plugin before 2.7.4 does not sanitise and escape some parameters, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks
CVSS 3.1MEDIUM 5.4·Network·Low privileges·User interaction·EPSS 0.00457·Published 2024-03-18·Fixed in 2.7.4CWE-79
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in BlueGlass Jobs for WordPress allows Reflected XSS.This issue affects Jobs for WordPress: from n/a through 2.7.5.
The Jobs for WordPress plugin before 2.7.8 does not sanitise and escape some of its Job settings, which could allow high privilege users such as contributor to perform Stored Cross-Site Scripting attacks
CVSS 3.1MEDIUM 5.9·Network·High privileges·User interaction·EPSS 0.00377·Published 2024-11-15·Fixed in 2.7.8CWE-79
The Jobs for WordPress plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘job-search’ parameter in all versions up to, and including, 2.7.5 due to insufficient input sanitization and output esc…