Read the docs
TI-2024-00757 Aliases CVE-2024-0820GHSA-mv3g-77hg-5wrg

Jobs for WordPress < 2.7.4 - Contributor+ Stored XSS

Priority MEDIUM 58CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.

Summary

The Jobs for WordPress plugin before 2.7.4 does not sanitise and escape some parameters, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00457 39th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Jobs for WordPress (Unknown): 2.7.4

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownJobs for WordPressbefore 2.7.42.7.4Patch availableCNA
  • Jobs for WordPress VendorUnknown Affected before 2.7.4 Fixed in 2.7.4 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:blueglass:jobs_for_wordpress:*:*:*:*:*:wordpress:*:*before 2.7.4VulnerableBlueGlass
  • cpe:2.3:a:blueglass:jobs_for_wordpress:*:*:*:*:*:wordpress:*:* Versions before 2.7.4 Vulnerable ·BlueGlass

Remediation

  • Fix · CNA Jobs for WordPress (Unknown) Fixed in 2.7.4

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-0820
  2. 2026-10-03 Alias added: GHSA-mv3g-77hg-5wrg

References

  • TI-2024-09367 Jobs for WordPress < 2.7.11 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.9
  • TI-2024-21224 WordPress Jobs for WordPress plugin <= 2.7.5 - Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
  • TI-2022-22032 WordPress Jobs for WordPress Plugin <= 2.5.11.2 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
  • TI-2024-09366 Jobs for WordPress < 2.7.8 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.9
  • TI-2024-02643 Jobs for WordPress <= 2.7.5 - Reflected Cross-Site Scripting via job-search CVSS 3.1MEDIUM 6.1
  • TI-2023-11258 WordPress Jobs for WordPress Plugin <= 2.5.10.2 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9

Sources