Jobs for WordPress < 2.7.8 - Contributor+ Stored XSS
Priority LOW 27CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Jobs for WordPress plugin before 2.7.8 does not sanitise and escape some of its Job settings, which could allow high privilege users such as contributor to perform Stored Cross-Site Scripting attacks
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00377 31st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Jobs for WordPress (Unknown): 2.7.8
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Jobs for WordPress | before 2.7.8 | 2.7.8 | Patch available | CNA |
- Jobs for WordPress VendorUnknown Affected before 2.7.8 Fixed in 2.7.8 Patch available CNA
Remediation
- Fix · CNA Jobs for WordPress (Unknown) Fixed in 2.7.8
Timeline
- 2026-10-02 Threatist record created from CVE-2024-10104
- 2026-10-03 Alias added: GHSA-f3mv-cjr3-hr9j
References
More BlueGlass Jobs For Wordpress vulnerabilities
- TI-2024-09367 Jobs for WordPress < 2.7.11 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.9
- TI-2024-00757 Jobs for WordPress < 2.7.4 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2024-21224 WordPress Jobs for WordPress plugin <= 2.7.5 - Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
- TI-2022-22032 WordPress Jobs for WordPress Plugin <= 2.5.11.2 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
- TI-2024-02643 Jobs for WordPress <= 2.7.5 - Reflected Cross-Site Scripting via job-search CVSS 3.1MEDIUM 6.1
- TI-2023-11258 WordPress Jobs for WordPress Plugin <= 2.5.10.2 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9
Sources
- CVE-2024-10104 · CVE Program
- CVE-2024-10104 · NVD
- FIRST EPSS
- GHSA-f3mv-cjr3-hr9j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences