Jobs for WordPress < 2.7.11 - Contributor+ Stored XSS
Priority MEDIUM 60CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Job Postings WordPress plugin before 2.7.11 does not sanitise and escape some of its settings, which could allow high privilege users such as contributor to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00323 25th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Job Postings (Unknown): 2.7.11
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Job Postings | before 2.7.11 | 2.7.11 | Patch available | CNA |
- Job Postings VendorUnknown Affected before 2.7.11 Fixed in 2.7.11 Patch available CNA
Remediation
- Fix · CNA Job Postings (Unknown) Fixed in 2.7.11
Timeline
- 2026-10-02 Threatist record created from CVE-2024-10105
- 2026-10-03 Alias added: GHSA-6vr9-h9pm-5frx
References
More BlueGlass Jobs For Wordpress vulnerabilities
- TI-2024-00757 Jobs for WordPress < 2.7.4 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2024-21224 WordPress Jobs for WordPress plugin <= 2.7.5 - Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
- TI-2022-22032 WordPress Jobs for WordPress Plugin <= 2.5.11.2 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
- TI-2024-09366 Jobs for WordPress < 2.7.8 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.9
- TI-2024-02643 Jobs for WordPress <= 2.7.5 - Reflected Cross-Site Scripting via job-search CVSS 3.1MEDIUM 6.1
- TI-2023-11258 WordPress Jobs for WordPress Plugin <= 2.5.10.2 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9
Sources
- CVE-2024-10105 · CVE Program
- CVE-2024-10105 · NVD
- FIRST EPSS
- GHSA-6vr9-h9pm-5frx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences