Read the docs

Dart

Records14All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical4CVSS 9.0–10.0
CVSS high2CVSS 7.0–8.9

Exploited now

Dart records in CISA KEV

No Dart vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

7 records in Dart Software Development Kit · all components

Priority MEDIUM 51

The implementation of backslash parsing in the Dart URI class for versions prior to 2.18 and Flutter versions prior to 3.30 differs from the WhatWG URL standards.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.01164 Published 2022-10-27 Fixed in 2.18.2, 3.3.3 CWE-20
Priority LOW 31

Dart SDK contains the HTTPClient in dart:io library whcih includes authorization headers when handling cross origin redirects.

CVSS 3.1MEDIUM 6.5 Network Low privileges No interaction EPSS 0.00998 Published 2022-02-18 Fixed in 2.16.0 CWE-305
TI-2021-05505 CVE-2021-22540 · GHSA-36mh-f84c-9fqq

XSS in Dart SDK

Priority LOW 28

Bad validation logic in the Dart SDK versions prior to 2.12.3 allow an attacker to use an XSS attack via DOM clobbering.

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.00681 Published 2021-04-22 Fixed in 2.12.3 CWE-79
Priority LOW 27

An improper HTML sanitization in Dart versions up to and including 2.7.1 and dev versions 2.8.0-dev.16.0, allows an attacker leveraging DOM Clobbering techniques to skip the sanitization and inject custom html/javascript…

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.00324 Published 2020-03-26 No fix listed CWE-79
Priority LOW 22

Bidirectional Unicode text can be interpreted and compiled differently than how it appears in editors which can be exploited to get nefarious code passed a code review by appearing benign.

CVSS 3.1MEDIUM 4.6 Network Low privileges User interaction EPSS 0.00618 Published 2022-01-05 Fixed in 2.15.0-268.18.beta CWE-284
Open these records in search →