Read the docs

Enviragallery

Records8All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical0CVSS 9.0–10.0
CVSS high1CVSS 7.0–8.9

Exploited now

Enviragallery records in CISA KEV

No Enviragallery vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

8 records

Priority MEDIUM 60

The Gallery Plugin for WordPress plugin before 1.8.4.7 does not escape the $_SERVER['REQUEST_URI'] parameter before outputting it back in an attribute, which could lead to Reflected Cross-Site Scripting in old web browse…

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.00737 Published 2022-10-31 Fixed in 1.8.4.7 CWE-79
Priority MEDIUM 55

The Gallery Plugin for WordPress WordPress plugin before 1.8.15 does not sanitise and escape some of its image settings, which could allow users with post-writing privilege such as Author to perform Cross-Site Scripting…

CVSS 3.1MEDIUM 4.8 Network High privileges User interaction EPSS 0.00354 Published 2024-09-11 Fixed in 1.8.15 CWE-79
Priority LOW 39

Missing Authorization vulnerability in Envira Gallery Team Envira Photo Gallery allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Envira Photo Gallery: from n/a through 1.8.14.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.00519 Published 2024-11-01 No fix listed CWE-862
Priority LOW 27

A stored cross-site scripting (XSS) issue in Envira Gallery Lite before 1.8.3.3 allows remote attackers to inject arbitrary JavaScript/HTML code via a POST /wp-admin/admin-ajax.php request with the meta[title] parameter.

CVSS 3.1MEDIUM 5.4 Network Low privileges User interaction EPSS 0.01359 Published 2021-01-15 No fix listed CWE-79
Priority LOW 26

Unvalidated input and lack of output encoding in the Envira Gallery Lite WordPress plugin, versions before 1.8.3.3, did not properly sanitise the images metadata (namely title) before outputting them in the generated gal…

CVSS 3.1MEDIUM 5.4 Network Low privileges User interaction EPSS 0.00661 Published 2021-03-18 Fixed in 1.8.3.3 CWE-79
Priority LOW 20

The Gallery Plugin for WordPress – Envira Photo Gallery plugin for WordPress is vulnerable to unauthorized modification of data due to an improper capability check on the 'envira_gallery_insert_images' function in all ve…

CVSS 3.1MEDIUM 4.3 Network Low privileges No interaction EPSS 0.00406 Published 2024-01-11 No fix listed CWE-862
Open these records in search →