Envira Gallery < 1.8.15 - Author+ Stored XSS
Priority MEDIUM 55CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Gallery Plugin for WordPress WordPress plugin before 1.8.15 does not sanitise and escape some of its image settings, which could allow users with post-writing privilege such as Author to perform Cross-Site Scripting attacks.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00354 29th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Gallery Plugin for WordPress (Unknown): 1.8.15
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Gallery Plugin for WordPress | before 1.8.15 | 1.8.15 | Patch available | CNA |
- Gallery Plugin for WordPress VendorUnknown Affected before 1.8.15 Fixed in 1.8.15 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:enviragallery:envira_gallery:*:*:*:*:lite:wordpress:*:* | before 1.8.15 | Vulnerable | Enviragallery |
- cpe:2.3:a:enviragallery:envira_gallery:*:*:*:*:lite:wordpress:*:* Versions before 1.8.15 Vulnerable ·Enviragallery
Remediation
- Fix · CNA Gallery Plugin for WordPress (Unknown) Fixed in 1.8.15
Timeline
- 2026-10-02 Threatist record created from CVE-2024-3899
- 2026-10-03 Alias added: GHSA-6c59-49qq-prw5
References
More Enviragallery Envira Gallery vulnerabilities
- TI-2022-02027 Envira Gallery Lite < 1.8.4.7 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2024-29514 WordPress Envira Gallery Lite plugin <= 1.8.14 - Broken Access Control vulnerability CVSS 3.1HIGH 8.8
- TI-2020-18088 A stored cross-site scripting (XSS) issue in Envira Gallery Lite before 1.8.3.3 allows… CVSS 3.1MEDIUM 5.4
- TI-2020-18087 A stored cross-site scripting (XSS) issue in Envira Gallery Lite before 1.8.3.3 allows… CVSS 3.1MEDIUM 5.4
- TI-2021-06418 Envira Gallery Lite < 1.8.3.3 - Authenticated Stored Cross-Site Scripting CVSS 3.1MEDIUM 5.4
- TI-2020-07461 A stored XSS vulnerability exists in the Envira Photo Gallery plugin through 1.7.6 for… CVSS 3.1MEDIUM 5.4
Sources
- CVE-2024-3899 · CVE Program
- CVE-2024-3899 · NVD
- FIRST EPSS
- GHSA-6c59-49qq-prw5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences