Envira Gallery Lite < 1.8.4.7 - Reflected Cross-Site Scripting
Priority MEDIUM 60CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Gallery Plugin for WordPress plugin before 1.8.4.7 does not escape the $_SERVER['REQUEST_URI'] parameter before outputting it back in an attribute, which could lead to Reflected Cross-Site Scripting in old web browsers
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00737 54th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Gallery Plugin for WordPress – Envira Photo Gallery (Unknown): 1.8.4.7
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Gallery Plugin for WordPress – Envira Photo Gallery | 1.8.4.7 to before 1.8.4.7 | 1.8.4.7 | Patch available | CNA |
- Gallery Plugin for WordPress – Envira Photo Gallery VendorUnknown Affected 1.8.4.7 to before 1.8.4.7 Fixed in 1.8.4.7 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:enviragallery:envira_gallery:*:*:*:*:lite:wordpress:*:* | before 1.8.4.7 | Vulnerable | Enviragallery |
- cpe:2.3:a:enviragallery:envira_gallery:*:*:*:*:lite:wordpress:*:* Versions before 1.8.4.7 Vulnerable ·Enviragallery
Remediation
- Fix · CNA Gallery Plugin for WordPress – Envira Photo Gallery (Unknown) Fixed in 1.8.4.7
Timeline
- 2026-10-02 Threatist record created from CVE-2022-2190
- 2026-10-03 Alias added: GHSA-qqx8-xhrr-9m9m
- 2026-10-16 EPSS moved to the 50th–90th percentile
References
More Enviragallery Envira Gallery vulnerabilities
- TI-2024-03638 Envira Gallery < 1.8.15 - Author+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2024-29514 WordPress Envira Gallery Lite plugin <= 1.8.14 - Broken Access Control vulnerability CVSS 3.1HIGH 8.8
- TI-2020-18088 A stored cross-site scripting (XSS) issue in Envira Gallery Lite before 1.8.3.3 allows… CVSS 3.1MEDIUM 5.4
- TI-2020-18087 A stored cross-site scripting (XSS) issue in Envira Gallery Lite before 1.8.3.3 allows… CVSS 3.1MEDIUM 5.4
- TI-2021-06418 Envira Gallery Lite < 1.8.3.3 - Authenticated Stored Cross-Site Scripting CVSS 3.1MEDIUM 5.4
- TI-2020-07461 A stored XSS vulnerability exists in the Envira Photo Gallery plugin through 1.7.6 for… CVSS 3.1MEDIUM 5.4
Sources
- CVE-2022-2190 · CVE Program
- CVE-2022-2190 · NVD
- FIRST EPSS
- GHSA-qqx8-xhrr-9m9m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences