Read the docs
TI-2021-06418 Aliases CVE-2021-24126GHSA-2564-4rf9-wv93

Envira Gallery Lite < 1.8.3.3 - Authenticated Stored Cross-Site Scripting

Priority LOW 26CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

Unvalidated input and lack of output encoding in the Envira Gallery Lite WordPress plugin, versions before 1.8.3.3, did not properly sanitise the images metadata (namely title) before outputting them in the generated gallery, which could lead to privilege escalation.

Why it matters now

EPSS 0.00661 51st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Envira Gallery Lite (Unknown): 1.8.3.3

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownEnvira Gallery Lite1.8.3.3 to before 1.8.3.31.8.3.3Patch availableCNA
  • Envira Gallery Lite VendorUnknown Affected 1.8.3.3 to before 1.8.3.3 Fixed in 1.8.3.3 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:enviragallery:envira_gallery:*:*:*:*:lite:wordpress:*:*before 1.8.3.3VulnerableEnviragallery
  • cpe:2.3:a:enviragallery:envira_gallery:*:*:*:*:lite:wordpress:*:* Versions before 1.8.3.3 Vulnerable ·Enviragallery

Remediation

  • Fix · CNA Envira Gallery Lite (Unknown) Fixed in 1.8.3.3

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-24126
  2. 2026-10-03 Alias added: GHSA-2564-4rf9-wv93
  3. 2026-10-07 EPSS moved to the 50th–90th percentile

References

  • TI-2022-02027 Envira Gallery Lite < 1.8.4.7 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
  • TI-2024-03638 Envira Gallery < 1.8.15 - Author+ Stored XSS CVSS 3.1MEDIUM 4.8
  • TI-2024-29514 WordPress Envira Gallery Lite plugin <= 1.8.14 - Broken Access Control vulnerability CVSS 3.1HIGH 8.8
  • TI-2020-18088 A stored cross-site scripting (XSS) issue in Envira Gallery Lite before 1.8.3.3 allows… CVSS 3.1MEDIUM 5.4
  • TI-2020-18087 A stored cross-site scripting (XSS) issue in Envira Gallery Lite before 1.8.3.3 allows… CVSS 3.1MEDIUM 5.4
  • TI-2020-07461 A stored XSS vulnerability exists in the Envira Photo Gallery plugin through 1.7.6 for… CVSS 3.1MEDIUM 5.4
See all 7 →

Sources