The Laravel framework versions between 11.9.0 and 11.35.1 are susceptible to reflected cross-site scripting due to an improper encoding of route parameters in the debug-mode error page.
CVSS 3.1HIGH 8.0·Network·No auth·User interaction·EPSS 0.00531·Published 2025-03-10·Fixed in 11.36.0CWE-79
The Laravel framework versions between 11.9.0 and 11.35.1 are susceptible to reflected cross-site scripting due to an improper encoding of request parameters in the debug-mode error page.
CVSS 3.1HIGH 8.0·Network·No auth·User interaction·EPSS 0.006·Published 2025-03-10·Fixed in 11.36.0CWE-79
The authentication method in Laravel 8.x through 9.x before 9.32.0 was discovered to be vulnerable to user enumeration via timeless timing attacks with HTTP/2 multiplexing.
Laravel Framework through 8.70.2 does not sufficiently block the upload of executable PHP content because Illuminate/Validation/Concerns/ValidatesAttributes.php lacks a check for .phar files, which are handled as applica…