OS Command injection vulnerability in function link in Filesystem.php in Laravel Framework before 5.8.17.
Priority MEDIUM 43CWE-78Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-78.
Summary
OS Command injection vulnerability in function link in Filesystem.php in Laravel Framework before 5.8.17.
Why it matters now
EPSS 0.02522 84th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed laravel/framework (Packagist): 5.8.17
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | laravel/framework (Packagist) | before 5.8.17 | 5.8.17 | Patch available | GHSA-w2pm-r78h-4m7v |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- laravel/framework (Packagist) Vendor— Affected before 5.8.17 Fixed in 5.8.17 Patch available GHSA-w2pm-r78h-4m7v
Remediation
- Fix · GHSA-w2pm-r78h-4m7v laravel/framework (Packagist) Fixed in 5.8.17 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-19316
- 2026-10-03 Alias added: GHSA-w2pm-r78h-4m7v
References
More Laravel Framework vulnerabilities
- TI-2024-34976 Laravel allows environment manipulation via query string CVSS 4.0HIGH 8.7
- TI-2024-12938 Laravel Reflected XSS via Route Parameter in Debug-Mode Error Page CVSS 3.1HIGH 8.0
- TI-2024-12937 Laravel Reflected XSS via Request Parameter in Debug-Mode Error Page CVSS 3.1HIGH 8.0
- TI-2022-19208 The authentication method in Laravel 8.x through 9.x before 9.32.0 was discovered to be… CVSS 3.1MEDIUM 5.3
- TI-2021-19485 Laravel Framework through 8.70.2 does not sufficiently block the upload of executable PHP… CVSS 3.1CRITICAL 9.8
- TI-2018-04655 Laravel 5.4.15 is vulnerable to Error based SQL injection in save.php via dhx_user and dhx_version parameters. CVSS 3.0HIGH 8.8
Sources
- CVE-2020-19316 · CVE Program
- CVE-2020-19316 · NVD
- FIRST EPSS
- GHSA-w2pm-r78h-4m7v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences