Laravel allows environment manipulation via query string
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-88.
Summary
Laravel is a web application framework. When the register_argc_argv php directive is set to on , and users call any URL with a special crafted query string, they are able to change the environment used by the framework when handling the request. The vulnerability fixed in 6.20.45, 7.30.7, 8.83.28, 9.52.17, 10.48.23, and 11.31.0. The framework now ignores argv values for environment detection on non-cli SAPIs.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Laravel | framework | before 6.20.45; 7.0.0 to before 7.30.7; 8.0.0 to before 8.83.28; 9.0.0 to before 9.52.17; 10.0.0 to before 10.48.23; 11.0.0 to before 11.31.0 | 6.20.45, 7.30.7, 8.83.28, 9.52.17, 10.48.23, 11.31.0 | Patch available | CNA |
| — | laravel/framework (Packagist) | before 6.20.45 | 6.20.45 | Patch available | GHSA-gv7v-rgg6-548h |
| — | laravel/framework (Packagist) | 7.0.0 to before 7.30.7 | 7.30.7 | Patch available | GHSA-gv7v-rgg6-548h |
| — | laravel/framework (Packagist) | 8.0.0 to before 8.83.28 | 8.83.28 | Patch available | GHSA-gv7v-rgg6-548h |
| — | laravel/framework (Packagist) | 9.0.0 to before 9.52.17 | 9.52.17 | Patch available | GHSA-gv7v-rgg6-548h |
| — | laravel/framework (Packagist) | 10.0.0 to before 10.48.23 | 10.48.23 | Patch available | GHSA-gv7v-rgg6-548h |
| — | laravel/framework (Packagist) | 11.0.0 to before 11.31.0 | 11.31.0 | Patch available | GHSA-gv7v-rgg6-548h |
- framework VendorLaravel Affected before 6.20.45; 7.0.0 to before 7.30.7; 8.0.0 to before 8.83.28; 9.0.0 to before 9.52.17; 10.0.0 to before 10.48.23; 11.0.0 to before 11.31.0 Fixed in 6.20.45, 7.30.7, 8.83.28, 9.52.17, 10.48.23, 11.31.0 Patch available CNA
- laravel/framework (Packagist) Vendor— Affected before 6.20.45 Fixed in 6.20.45 Patch available GHSA-gv7v-rgg6-548h
- laravel/framework (Packagist) Vendor— Affected 7.0.0 to before 7.30.7 Fixed in 7.30.7 Patch available GHSA-gv7v-rgg6-548h
- laravel/framework (Packagist) Vendor— Affected 8.0.0 to before 8.83.28 Fixed in 8.83.28 Patch available GHSA-gv7v-rgg6-548h
- laravel/framework (Packagist) Vendor— Affected 9.0.0 to before 9.52.17 Fixed in 9.52.17 Patch available GHSA-gv7v-rgg6-548h
- laravel/framework (Packagist) Vendor— Affected 10.0.0 to before 10.48.23 Fixed in 10.48.23 Patch available GHSA-gv7v-rgg6-548h
- laravel/framework (Packagist) Vendor— Affected 11.0.0 to before 11.31.0 Fixed in 11.31.0 Patch available GHSA-gv7v-rgg6-548h
CPE configurations NVD · 2
Remediation
- Fix · CNA framework (laravel) Fixed in 6.20.45, 7.30.7, 8.83.28, 9.52.17, 10.48.23, 11.31.0
- Fix · GHSA-gv7v-rgg6-548h laravel/framework (Packagist) Fixed in 6.20.45 Advisory →
- Fix · GHSA-gv7v-rgg6-548h laravel/framework (Packagist) Fixed in 7.30.7 Advisory →
- Fix · GHSA-gv7v-rgg6-548h laravel/framework (Packagist) Fixed in 8.83.28 Advisory →
- Fix · GHSA-gv7v-rgg6-548h laravel/framework (Packagist) Fixed in 9.52.17 Advisory →
- Fix · GHSA-gv7v-rgg6-548h laravel/framework (Packagist) Fixed in 10.48.23 Advisory →
- Fix · GHSA-gv7v-rgg6-548h laravel/framework (Packagist) Fixed in 11.31.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-52301
- 2026-10-03 Alias added: GHSA-gv7v-rgg6-548h
References
Advisory 4
More Laravel Framework vulnerabilities
- TI-2024-12938 Laravel Reflected XSS via Route Parameter in Debug-Mode Error Page CVSS 3.1HIGH 8.0
- TI-2024-12937 Laravel Reflected XSS via Request Parameter in Debug-Mode Error Page CVSS 3.1HIGH 8.0
- TI-2022-19208 The authentication method in Laravel 8.x through 9.x before 9.32.0 was discovered to be… CVSS 3.1MEDIUM 5.3
- TI-2021-19485 Laravel Framework through 8.70.2 does not sufficiently block the upload of executable PHP… CVSS 3.1CRITICAL 9.8
- TI-2020-13600 OS Command injection vulnerability in function link in Filesystem.php in Laravel Framework before 5.8.17. CVSS 3.1HIGH 8.8
- TI-2018-04655 Laravel 5.4.15 is vulnerable to Error based SQL injection in save.php via dhx_user and dhx_version parameters. CVSS 3.0HIGH 8.8
Sources
- CVE-2024-52301 · CVE Program
- CVE-2024-52301 · NVD
- FIRST EPSS
- GHSA-gv7v-rgg6-548h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences