Read the docs
TI-2024-04765 Aliases CVE-2024-5129GHSA-mj9w-3qrj-p3gj

Privilege Escalation Vulnerability in lunary-ai/lunary

Priority HIGH 75CWE-862Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
None · High · Low
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-862.

Summary

A Privilege Escalation Vulnerability exists in lunary-ai/lunary version 1.2.2, where any user can delete any datasets due to missing authorization checks. The vulnerability is present in the dataset deletion functionality, where the application fails to verify if the user requesting the deletion has the appropriate permissions. This allows unauthorized users to send a DELETE request to the server and delete any dataset by specifying its ID. The issue is located in the datasets.delete function within the datasets index file.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0045 39th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed lunary-ai/lunary (lunary-ai): 1.2.8

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
lunary-ailunary-ai/lunarybefore 1.2.81.2.8Patch availableCNA
  • lunary-ai/lunary Vendorlunary-ai Affected before 1.2.8 Fixed in 1.2.8 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:lunary:lunary:*:*:*:*:*:*:*:*before 1.2.8Vulnerablelunary-ai
  • cpe:2.3:a:lunary:lunary:*:*:*:*:*:*:*:* Versions before 1.2.8 Vulnerable ·lunary-ai

Remediation

  • Fix · CNA lunary-ai/lunary (lunary-ai) Fixed in 1.2.8

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    lunary-ai/lunary 1.2.8

    2 records Highest priority Priority HIGH 1 HIGH, 1 LOW

    Other records, highest priority first

    • TI-2024-04766 Incorrect Authorization in lunary-ai/lunaryPriority LOW 39

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-5129
  2. 2026-10-03 Alias added: GHSA-mj9w-3qrj-p3gj

References

  • TI-2024-08445 Improper Authorization in lunary-ai/lunary CVSS 3.1CRITICAL 9.8
  • TI-2024-06910 SQL Injection in lunary-ai/lunary CVSS 3.1CRITICAL 9.8
  • TI-2024-03859 Incorrect Authorization in lunary-ai/lunary CVSS 3.1CRITICAL 9.8
  • TI-2024-06928 Improper Access Control in lunary-ai/lunary CVSS 3.1CRITICAL 9.1
  • TI-2024-03267 Exposure of Sensitive Information in lunary-ai/lunary CVSS 3.1CRITICAL 9.1
  • TI-2024-03266 Exposure of Sensitive Information in lunary-ai/lunary CVSS 3.1CRITICAL 9.1
See all 68 →

Sources