Read the docs

MetaSlider

Records11All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical2CVSS 9.0–10.0
CVSS high1CVSS 7.0–8.9

Exploited now

MetaSlider records in CISA KEV

No MetaSlider vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

11 records

Priority MEDIUM 60

The Slider, Gallery, and Carousel by MetaSlider WordPress plugin 3.29.0 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used agai…

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.00458 Published 2023-04-17 Fixed in 3.29.1
Priority MEDIUM 50

Deserialization of Untrusted Data vulnerability in MetaSlider Responsive Slider by MetaSlider ml-slider allows Object Injection.This issue affects Responsive Slider by MetaSlider: from n/a through <= 3.94.0.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.00654 Published 2025-02-22 No fix listed CWE-502
Priority MEDIUM 50

The Slider, Gallery, and Carousel by MetaSlider WordPress plugin before 3.95.0 does not sanitise and escape some of its settings, which could allow high privilege users such as editor to perform Stored Cross-Site Scripti…

CVSS 3.1LOW 3.5 Network High privileges User interaction EPSS 0.00297 Published 2025-03-24 Fixed in 3.95.0 CWE-79
Priority MEDIUM 50

The Slider, Gallery, and Carousel by MetaSlider WordPress plugin before 3.95.0 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scriptin…

CVSS 3.1LOW 3.5 Network High privileges User interaction EPSS 0.00267 Published 2025-03-24 Fixed in 3.95.0 CWE-79
Priority LOW 29

The Slider, Gallery, and Carousel by MetaSlider – Image Slider, Video Slider plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'delay' Post Meta Setting in all versions up to, and including, 3.111.0 d…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00435 Published 2026-08-06 No fix listed CWE-79
Priority LOW 28

The Slider, Gallery, and Carousel by MetaSlider plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘aria-label’ parameter in all versions up to, and including, 3.98.0 due to insufficient input sani…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00267 Published 2025-06-14 No fix listed CWE-79
Priority LOW 28

The Slider, Gallery, and Carousel by MetaSlider – Responsive WordPress Slideshows plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'metaslider' shortcode in all versions up to, and inclu…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00343 Published 2024-04-11 No fix listed CWE-79
Priority LOW 23

The Slider, Gallery, and Carousel by MetaSlider WordPress plugin before 3.27.9 does not sanitise and escape some of its Gallery Image parameters, which could allow high privilege users such as admin to perform Stored Cro…

CVSS 3.1MEDIUM 4.8 Network High privileges User interaction EPSS 0.00597 Published 2022-10-10 Fixed in 3.27.9 CWE-79
Open these records in search →