Slider, Gallery, Carousel by MetaSlider < 3.95.0 - Editor+ Stored XSS
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Slider, Gallery, and Carousel by MetaSlider WordPress plugin before 3.95.0 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Slider, Gallery, and Carousel by MetaSlider | before 3.95.0 | 3.95.0 | Patch available | CNA |
- Slider, Gallery, and Carousel by MetaSlider VendorUnknown Affected before 3.95.0 Fixed in 3.95.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:metaslider:slider\,_gallery\,_and_carousel:*:*:*:*:*:wordpress:*:* | before 3.95.0 | Vulnerable | MetaSlider |
- cpe:2.3:a:metaslider:slider\,_gallery\,_and_carousel:*:*:*:*:*:wordpress:*:* Versions before 3.95.0 Vulnerable ·MetaSlider
Remediation
- Fix · CNA Slider, Gallery, and Carousel by MetaSlider (Unknown) Fixed in 3.95.0
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Slider, Gallery, and Carousel by MetaSlider 3.95.0
2 records Highest priority Priority MEDIUM 2 MEDIUM
Other records, highest priority first
- TI-2025-01028 Slider, Gallery, Carousel by MetaSlider < 3.95.0 - Editor+ Stored XSSPriority MEDIUM 50
Timeline
- 2026-10-02 Threatist record created from CVE-2025-1062
- 2026-10-03 Alias added: GHSA-wgx4-5qgj-vf8m
References
More MetaSlider Slider, Gallery, And Carousel vulnerabilities
- TI-2023-01392 Responsive WordPress Slideshows 3.29.0 - Reflected XSS CVSS 3.1MEDIUM 6.1
- TI-2025-01028 Slider, Gallery, Carousel by MetaSlider < 3.95.0 - Editor+ Stored XSS CVSS 3.1LOW 3.5
- TI-2025-04792 Cross-site scripting in MetaSlider Slider, Gallery, and Carousel by MetaSlider – Image… CVSS 3.1MEDIUM 6.4
- TI-2024-03080 Cross-site scripting in MetaSlider Slider, Gallery, and Carousel by MetaSlider – Image… CVSS 3.1MEDIUM 6.4
- TI-2022-02617 Slider, Gallery, and Carousel by MetaSlider < 3.27.9 - Admin+ Stored Cross Site Scripting CVSS 3.1MEDIUM 4.8
Sources
- CVE-2025-1062 · CVE Program
- CVE-2025-1062 · NVD
- FIRST EPSS
- GHSA-wgx4-5qgj-vf8m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences