Responsive WordPress Slideshows 3.29.0 - Reflected XSS
Priority MEDIUM 60Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Slider, Gallery, and Carousel by MetaSlider WordPress plugin 3.29.0 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00458 39th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Slider, Gallery, and Carousel by MetaSlider (Unknown): 3.29.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Slider, Gallery, and Carousel by MetaSlider | 3.29.0 to before 3.29.1 | 3.29.1 | Patch available | CNA |
- Slider, Gallery, and Carousel by MetaSlider VendorUnknown Affected 3.29.0 to before 3.29.1 Fixed in 3.29.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:metaslider:slider\,_gallery\,_and_carousel:*:*:*:*:*:wordpress:*:* | before 3.29.1 | Vulnerable | MetaSlider |
- cpe:2.3:a:metaslider:slider\,_gallery\,_and_carousel:*:*:*:*:*:wordpress:*:* Versions before 3.29.1 Vulnerable ·MetaSlider
Remediation
- Fix · CNA Slider, Gallery, and Carousel by MetaSlider (Unknown) Fixed in 3.29.1
Timeline
- 2026-10-02 Threatist record created from CVE-2023-1473
- 2026-10-03 Alias added: GHSA-53gc-hw42-vfp5
References
More MetaSlider Slider, Gallery, And Carousel vulnerabilities
- TI-2025-01028 Slider, Gallery, Carousel by MetaSlider < 3.95.0 - Editor+ Stored XSS CVSS 3.1LOW 3.5
- TI-2025-00901 Slider, Gallery, Carousel by MetaSlider < 3.95.0 - Editor+ Stored XSS CVSS 3.1LOW 3.5
- TI-2025-04792 Cross-site scripting in MetaSlider Slider, Gallery, and Carousel by MetaSlider – Image… CVSS 3.1MEDIUM 6.4
- TI-2024-03080 Cross-site scripting in MetaSlider Slider, Gallery, and Carousel by MetaSlider – Image… CVSS 3.1MEDIUM 6.4
- TI-2022-02617 Slider, Gallery, and Carousel by MetaSlider < 3.27.9 - Admin+ Stored Cross Site Scripting CVSS 3.1MEDIUM 4.8
Sources
- CVE-2023-1473 · CVE Program
- CVE-2023-1473 · NVD
- FIRST EPSS
- GHSA-53gc-hw42-vfp5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences