Slider, Gallery, and Carousel by MetaSlider < 3.27.9 - Admin+ Stored Cross Site Scripting
Priority LOW 23CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Slider, Gallery, and Carousel by MetaSlider WordPress plugin before 3.27.9 does not sanitise and escape some of its Gallery Image parameters, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Why it matters now
EPSS 0.00597 48th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Slider, Gallery, and Carousel by MetaSlider – Responsive WordPress Plugin (Unknown): 3.27.9
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Slider, Gallery, and Carousel by MetaSlider – Responsive WordPress Plugin | 3.27.9 to before 3.27.9 | 3.27.9 | Patch available | CNA |
- Slider, Gallery, and Carousel by MetaSlider – Responsive WordPress Plugin VendorUnknown Affected 3.27.9 to before 3.27.9 Fixed in 3.27.9 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:metaslider:slider\,_gallery\,_and_carousel:*:*:*:*:*:wordpress:*:* | before 3.27.9 | Vulnerable | MetaSlider |
- cpe:2.3:a:metaslider:slider\,_gallery\,_and_carousel:*:*:*:*:*:wordpress:*:* Versions before 3.27.9 Vulnerable ·MetaSlider
Remediation
- Fix · CNA Slider, Gallery, and Carousel by MetaSlider – Responsive WordPress Plugin (Unknown) Fixed in 3.27.9
Timeline
- 2026-10-02 Threatist record created from CVE-2022-2823
- 2026-10-03 Alias added: GHSA-jwq4-3rxm-96c4
References
More MetaSlider Slider, Gallery, And Carousel vulnerabilities
- TI-2023-01392 Responsive WordPress Slideshows 3.29.0 - Reflected XSS CVSS 3.1MEDIUM 6.1
- TI-2025-01028 Slider, Gallery, Carousel by MetaSlider < 3.95.0 - Editor+ Stored XSS CVSS 3.1LOW 3.5
- TI-2025-00901 Slider, Gallery, Carousel by MetaSlider < 3.95.0 - Editor+ Stored XSS CVSS 3.1LOW 3.5
- TI-2025-04792 Cross-site scripting in MetaSlider Slider, Gallery, and Carousel by MetaSlider – Image… CVSS 3.1MEDIUM 6.4
- TI-2024-03080 Cross-site scripting in MetaSlider Slider, Gallery, and Carousel by MetaSlider – Image… CVSS 3.1MEDIUM 6.4
Sources
- CVE-2022-2823 · CVE Program
- CVE-2022-2823 · NVD
- FIRST EPSS
- GHSA-jwq4-3rxm-96c4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences