A vulnerability in Swagger-Parser's (version <= 1.0.30) yaml parsing functionality results in arbitrary code being executed when a maliciously crafted yaml Open-API specification is parsed.
CVSS 3.0HIGH 8.8·Network·No auth·User interaction·EPSS 0.01705·Published 2017-11-17·Fixed in 2.2.2, 1.0.31CWE-502
A vulnerability in Swagger-Parser's version <= 1.0.30 and Swagger codegen version <= 2.2.2 yaml parsing functionality results in arbitrary code being executed when a maliciously crafted yaml Open-API specification is par…
CVSS 3.0HIGH 8.8·Network·No auth·User interaction·EPSS 0.01623·Published 2017-11-27·Fixed in 1.0.31, 2.2.2CWE-502