Cross-site scripting in Vektor,Inc. VK All in One Expansion Unit
Priority LOW 22CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
Cross-site scripting vulnerability exists in VK All in One Expansion Unit versions prior to 9.100.1.0. If this vulnerability is exploited, an arbitrary script may be executed on the web browser of the user who is accessing the web site using the product.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0031 24th percentileScored 2026-11-07
Fix Fixed VK All in One Expansion Unit (Vektor,Inc.): 9.100.1.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Vektor,Inc. | VK All in One Expansion Unit | before 9.100.1.0 | 9.100.1.0 | Patch available | CNA |
- VK All in One Expansion Unit VendorVektor,Inc. Affected before 9.100.1.0 Fixed in 9.100.1.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:vektor-inc:vk_all_in_one_expansion_unit:*:*:*:*:*:wordpress:*:* | before 9.100.1.0 | Vulnerable | Vektor,Inc. |
- cpe:2.3:a:vektor-inc:vk_all_in_one_expansion_unit:*:*:*:*:*:wordpress:*:* Versions before 9.100.1.0 Vulnerable ·Vektor,Inc.
Remediation
- Fix · CNA VK All in One Expansion Unit (Vektor,Inc.) Fixed in 9.100.1.0
Timeline
- 2026-10-02 Threatist record created from CVE-2024-52268
- 2026-10-03 Alias added: GHSA-mh3p-j9c3-vqpj
References
More Vektor,Inc. Vk All In One Expansion Unit vulnerabilities
- TI-2023-00888 VK All in One Expansion Unit < 9.87.1.0 - Reflected XSS CVSS 3.1MEDIUM 6.1
- TI-2023-00220 VK All in One Expansion Unit < 9.86.0.0 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2024-01949 VK All in One Expansion Unit <= 9.95.0.1 - Information Exposure CVSS 3.1MEDIUM 6.5
- TI-2024-25262 WordPress VK All in One Expansion Unit plugin <= 9.99.1.0 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
- TI-2024-02015 VK All in One Expansion Unit <= 9.96.0.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via className CVSS 3.1MEDIUM 6.4
- TI-2023-12913 Cross-site scripting in Vektor,Inc. VK All in One Expansion Unit CVSS 3.1MEDIUM 5.4
Sources
- CVE-2024-52268 · CVE Program
- CVE-2024-52268 · NVD
- FIRST EPSS
- GHSA-mh3p-j9c3-vqpj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences