Cross-site scripting (XSS) vulnerability in cake/libs/error.php in CakePHP before…
Priority LOW 22CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in cake/libs/error.php in CakePHP before 1.1.7.3363 allows remote attackers to inject arbitrary web script or HTML via the URL, which is reflected back in a 404 ("Not Found") error page. NOTE: some of these details are obtained from third party information.
Why it matters now
EPSS 0.01207 68th percentileScored 2026-11-07
Fix Fixed cakephp/cakephp (Packagist): 1.1.7.3363
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | cakephp/cakephp (Packagist) | 1.0.1.2708 to before 1.1.7.3363 | 1.1.7.3363 | Patch available | GHSA-vc29-mvwv-wpcq |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- cakephp/cakephp (Packagist) Vendor— Affected 1.0.1.2708 to before 1.1.7.3363 Fixed in 1.1.7.3363 Patch available GHSA-vc29-mvwv-wpcq
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:cakephp:cakephp:*:*:*:*:*:*:*:* | up to 1.1.6.3264 | Vulnerable | cakephp |
| cpe:2.3:a:cakephp:cakephp:1.0.1.2708:*:*:*:*:*:*:* | 1.0.1.2708 | Vulnerable | cakephp |
| cpe:2.3:a:cakephp:cakephp:1.1.3.2967:*:*:*:*:*:*:* | 1.1.3.2967 | Vulnerable | cakephp |
| cpe:2.3:a:cakephp:cakephp:1.1.4.3104:*:*:*:*:*:*:* | 1.1.4.3104 | Vulnerable | cakephp |
| cpe:2.3:a:cakephp:cakephp:1.1.5.3148:*:*:*:*:*:*:* | 1.1.5.3148 | Vulnerable | cakephp |
- cpe:2.3:a:cakephp:cakephp:*:*:*:*:*:*:*:* Versions up to 1.1.6.3264 Vulnerable ·cakephp
- cpe:2.3:a:cakephp:cakephp:1.0.1.2708:*:*:*:*:*:*:* Versions 1.0.1.2708 Vulnerable ·cakephp
- cpe:2.3:a:cakephp:cakephp:1.1.3.2967:*:*:*:*:*:*:* Versions 1.1.3.2967 Vulnerable ·cakephp
- cpe:2.3:a:cakephp:cakephp:1.1.4.3104:*:*:*:*:*:*:* Versions 1.1.4.3104 Vulnerable ·cakephp
- cpe:2.3:a:cakephp:cakephp:1.1.5.3148:*:*:*:*:*:*:* Versions 1.1.5.3148 Vulnerable ·cakephp
Remediation
- Fix · GHSA-vc29-mvwv-wpcq cakephp/cakephp (Packagist) Fixed in 1.1.7.3363 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2006-4067
- 2026-10-03 Alias added: GHSA-vc29-mvwv-wpcq
References
More Cakephp vulnerabilities
- TI-2010-04068 The _validatePost function in libs/controller/components/security.php in CakePHP 1.3.x… CVSS 2.0HIGH 7.5
- TI-2026-19037 CakePHP PaginatorHelper::limitControl() vulnerable to reflected cross-site-scripting CVSS 3.1MEDIUM 5.4
- TI-2023-08901 Database Query::offset() and limit() vulnerable to SQL injection in cakephp CVSS 3.1CRITICAL 9.8
- TI-2016-04142 The clientIp function in CakePHP 3.2.4 and earlier allows remote attackers to spoof their… CVSS 3.0HIGH 7.5
- TI-2015-06899 CakePHP 2.x and 3.x before 3.1.5 might allow remote attackers to bypass the CSRF… CVSS 3.0HIGH 8.8
- TI-2020-17913 A vulnerability exists in CakePHP versions 4.0.x through 4.1.3. CVSS 3.1HIGH 8.8
Sources
- CVE-2006-4067 · CVE Program
- CVE-2006-4067 · NVD
- FIRST EPSS
- GHSA-vc29-mvwv-wpcq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences