The clientIp function in CakePHP 3.2.4 and earlier allows remote attackers to spoof their…
Priority MEDIUM 41CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.
Summary
The clientIp function in CakePHP 3.2.4 and earlier allows remote attackers to spoof their IP via the CLIENT-IP HTTP header.
Why it matters now
EPSS 0.05146 92nd percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by the CNA and NVD
Fix Fixed cakephp/cakephp (Packagist): 2.6.13, 2.7.11, 2.8.2 +3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | cakephp/cakephp (Packagist) | 1.2.0 to before 2.6.13 | 2.6.13 | Patch available | GHSA-j8p3-8m69-2hqq |
| — | cakephp/cakephp (Packagist) | 2.7.0-rc1 to before 2.7.11 | 2.7.11 | Patch available | GHSA-j8p3-8m69-2hqq |
| — | cakephp/cakephp (Packagist) | 2.8.0-rc1 to before 2.8.2 | 2.8.2 | Patch available | GHSA-j8p3-8m69-2hqq |
| — | cakephp/cakephp (Packagist) | 3.0.0-rc1 to before 3.0.17 | 3.0.17 | Patch available | GHSA-j8p3-8m69-2hqq |
| — | cakephp/cakephp (Packagist) | 3.1.0-beta1 to before 3.1.12 | 3.1.12 | Patch available | GHSA-j8p3-8m69-2hqq |
| — | cakephp/cakephp (Packagist) | 3.2.0-rc1 to before 3.2.5 | 3.2.5 | Patch available | GHSA-j8p3-8m69-2hqq |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- cakephp/cakephp (Packagist) Vendor— Affected 1.2.0 to before 2.6.13 Fixed in 2.6.13 Patch available GHSA-j8p3-8m69-2hqq
- cakephp/cakephp (Packagist) Vendor— Affected 2.7.0-rc1 to before 2.7.11 Fixed in 2.7.11 Patch available GHSA-j8p3-8m69-2hqq
- cakephp/cakephp (Packagist) Vendor— Affected 2.8.0-rc1 to before 2.8.2 Fixed in 2.8.2 Patch available GHSA-j8p3-8m69-2hqq
- cakephp/cakephp (Packagist) Vendor— Affected 3.0.0-rc1 to before 3.0.17 Fixed in 3.0.17 Patch available GHSA-j8p3-8m69-2hqq
- cakephp/cakephp (Packagist) Vendor— Affected 3.1.0-beta1 to before 3.1.12 Fixed in 3.1.12 Patch available GHSA-j8p3-8m69-2hqq
- cakephp/cakephp (Packagist) Vendor— Affected 3.2.0-rc1 to before 3.2.5 Fixed in 3.2.5 Patch available GHSA-j8p3-8m69-2hqq
Remediation
- Fix · GHSA-j8p3-8m69-2hqq cakephp/cakephp (Packagist) Fixed in 2.6.13 Advisory →
- Fix · GHSA-j8p3-8m69-2hqq cakephp/cakephp (Packagist) Fixed in 2.7.11 Advisory →
- Fix · GHSA-j8p3-8m69-2hqq cakephp/cakephp (Packagist) Fixed in 2.8.2 Advisory →
- Fix · GHSA-j8p3-8m69-2hqq cakephp/cakephp (Packagist) Fixed in 3.0.17 Advisory →
- Fix · GHSA-j8p3-8m69-2hqq cakephp/cakephp (Packagist) Fixed in 3.1.12 Advisory →
- Fix · GHSA-j8p3-8m69-2hqq cakephp/cakephp (Packagist) Fixed in 3.2.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-4793
- 2026-10-03 Alias added: GHSA-j8p3-8m69-2hqq
References
More Cakephp vulnerabilities
- TI-2010-04068 The _validatePost function in libs/controller/components/security.php in CakePHP 1.3.x… CVSS 2.0HIGH 7.5
- TI-2026-19037 CakePHP PaginatorHelper::limitControl() vulnerable to reflected cross-site-scripting CVSS 3.1MEDIUM 5.4
- TI-2023-08901 Database Query::offset() and limit() vulnerable to SQL injection in cakephp CVSS 3.1CRITICAL 9.8
- TI-2015-06899 CakePHP 2.x and 3.x before 3.1.5 might allow remote attackers to bypass the CSRF… CVSS 3.0HIGH 8.8
- TI-2020-17913 A vulnerability exists in CakePHP versions 4.0.x through 4.1.3. CVSS 3.1HIGH 8.8
- TI-2019-08553 An issue was discovered in SmtpTransport in CakePHP 3.7.6. CVSS 3.0HIGH 7.5
Sources
- CVE-2016-4793 · CVE Program
- CVE-2016-4793 · NVD
- FIRST EPSS
- GHSA-j8p3-8m69-2hqq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences