Read the docs
TI-2006-04847 Aliases CVE-2006-5031GHSA-rw73-xmpv-j5x2

Directory traversal vulnerability in app/webroot/js/vendors.php in Cake Software…

Priority LOW 33CWE-22Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
Partial · None · None
Fix status
Fixed

Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-22 and the CVSS impact.

Summary

Directory traversal vulnerability in app/webroot/js/vendors.php in Cake Software Foundation CakePHP before 1.1.8.3544 allows remote attackers to read arbitrary files via a .. (dot dot) in the file parameter, followed by a filename ending with "%00" and a .js filename.

Why it matters now

EPSS 0.07674 94th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed cakephp/cakephp (Packagist): 1.1.8.3544

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—cakephp/cakephp (Packagist)1.0.1.2708 to before 1.1.8.35441.1.8.3544Patch availableGHSA-rw73-xmpv-j5x2
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • cakephp/cakephp (Packagist) Vendor— Affected 1.0.1.2708 to before 1.1.8.3544 Fixed in 1.1.8.3544 Patch available GHSA-rw73-xmpv-j5x2

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:cakephp:cakephp:*:*:*:*:*:*:*:*up to 1.1.7.3363Vulnerablecakephp
  • cpe:2.3:a:cakephp:cakephp:*:*:*:*:*:*:*:* Versions up to 1.1.7.3363 Vulnerable ·cakephp

Remediation

  • Fix · GHSA-rw73-xmpv-j5x2 cakephp/cakephp (Packagist) Fixed in 1.1.8.3544 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2006-5031
  2. 2026-10-03 Alias added: GHSA-rw73-xmpv-j5x2

References

  • TI-2010-04068 The _validatePost function in libs/controller/components/security.php in CakePHP 1.3.x… CVSS 2.0HIGH 7.5
  • TI-2026-19037 CakePHP PaginatorHelper::limitControl() vulnerable to reflected cross-site-scripting CVSS 3.1MEDIUM 5.4
  • TI-2023-08901 Database Query::offset() and limit() vulnerable to SQL injection in cakephp CVSS 3.1CRITICAL 9.8
  • TI-2016-04142 The clientIp function in CakePHP 3.2.4 and earlier allows remote attackers to spoof their… CVSS 3.0HIGH 7.5
  • TI-2015-06899 CakePHP 2.x and 3.x before 3.1.5 might allow remote attackers to bypass the CSRF… CVSS 3.0HIGH 8.8
  • TI-2020-17913 A vulnerability exists in CakePHP versions 4.0.x through 4.1.3. CVSS 3.1HIGH 8.8
See all 10 →

Sources