Cross-site scripting (XSS) vulnerability in feedparser.py in Universal Feed Parser (aka…
Priority LOW 27CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in feedparser.py in Universal Feed Parser (aka feedparser or python-feedparser) before 5.0 allows remote attackers to inject arbitrary web script or HTML via vectors involving nested CDATA stanzas.
Why it matters now
EPSS 0.0453 91st percentileScored 2026-11-07
Public exploit Yes 3 exploit referencesTagged by NVD
Fix Fixed feedparser (PyPI): 5.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | feedparser (PyPI) | before 5.0 | 5.0 | Patch available | GHSA-3mwg-gp5g-fv3q |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- feedparser (PyPI) Vendor— Affected before 5.0 Fixed in 5.0 Patch available GHSA-3mwg-gp5g-fv3q
CPE configurations NVD · 9
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mark_pilgrim:feedparser:*:*:*:*:*:*:*:* | up to 4.1 | Vulnerable | Mark Pilgrim |
| cpe:2.3:a:mark_pilgrim:feedparser:3.0:*:*:*:*:*:*:* | 3.0 | Vulnerable | Mark Pilgrim |
| cpe:2.3:a:mark_pilgrim:feedparser:3.0.1:*:*:*:*:*:*:* | 3.0.1 | Vulnerable | Mark Pilgrim |
| cpe:2.3:a:mark_pilgrim:feedparser:3.1:*:*:*:*:*:*:* | 3.1 | Vulnerable | Mark Pilgrim |
| cpe:2.3:a:mark_pilgrim:feedparser:3.2:*:*:*:*:*:*:* | 3.2 | Vulnerable | Mark Pilgrim |
| cpe:2.3:a:mark_pilgrim:feedparser:3.3:*:*:*:*:*:*:* | 3.3 | Vulnerable | Mark Pilgrim |
| cpe:2.3:a:mark_pilgrim:feedparser:4.0:*:*:*:*:*:*:* | 4.0 | Vulnerable | Mark Pilgrim |
| cpe:2.3:a:mark_pilgrim:feedparser:4.0.1:*:*:*:*:*:*:* | 4.0.1 | Vulnerable | Mark Pilgrim |
| cpe:2.3:a:mark_pilgrim:feedparser:4.0.2:*:*:*:*:*:*:* | 4.0.2 | Vulnerable | Mark Pilgrim |
- cpe:2.3:a:mark_pilgrim:feedparser:*:*:*:*:*:*:*:* Versions up to 4.1 Vulnerable ·Mark Pilgrim
- cpe:2.3:a:mark_pilgrim:feedparser:3.0:*:*:*:*:*:*:* Versions 3.0 Vulnerable ·Mark Pilgrim
- cpe:2.3:a:mark_pilgrim:feedparser:3.0.1:*:*:*:*:*:*:* Versions 3.0.1 Vulnerable ·Mark Pilgrim
- cpe:2.3:a:mark_pilgrim:feedparser:3.1:*:*:*:*:*:*:* Versions 3.1 Vulnerable ·Mark Pilgrim
- cpe:2.3:a:mark_pilgrim:feedparser:3.2:*:*:*:*:*:*:* Versions 3.2 Vulnerable ·Mark Pilgrim
- cpe:2.3:a:mark_pilgrim:feedparser:3.3:*:*:*:*:*:*:* Versions 3.3 Vulnerable ·Mark Pilgrim
- cpe:2.3:a:mark_pilgrim:feedparser:4.0:*:*:*:*:*:*:* Versions 4.0 Vulnerable ·Mark Pilgrim
- cpe:2.3:a:mark_pilgrim:feedparser:4.0.1:*:*:*:*:*:*:* Versions 4.0.1 Vulnerable ·Mark Pilgrim
- cpe:2.3:a:mark_pilgrim:feedparser:4.0.2:*:*:*:*:*:*:* Versions 4.0.2 Vulnerable ·Mark Pilgrim
Remediation
- Fix · GHSA-3mwg-gp5g-fv3q feedparser (PyPI) Fixed in 5.0 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2009-5065
- 2026-10-03 Alias added: GHSA-3mwg-gp5g-fv3q
References
Exploit 3
Advisory 3
Other 6
- [opensuse-updates] 20110408 openSUSE-SU-2011:0314-1 (moderate): python-feedparser security update
- http://support.novell.com/security/cve/CVE-2009-5065.html
- https://github.com/kurtmckee/feedparser
- https://github.com/pypa/advisory-database/tree/main/vulns/feedparser/PYSEC-2011-18.yaml
- https://web.archive.org/web/20200228153921/http://www.securityfocus.com/bid/47177
- https://web.archive.org/web/20210329050642/http://www.mandriva.com/security/advisories?name=MDVSA-2011:082
More Mark Pilgrim Feedparser vulnerabilities
- TI-2011-01008 feedparser.py in Universal Feed Parser (aka feedparser or python-feedparser) before 5.0.1… CVSS 2.0MEDIUM 5.0
- TI-2012-02535 Universal Feed Parser (aka feedparser or python-feedparser) before 5.1.2 allows remote… CVSS 2.0MEDIUM 5.0
- TI-2011-01010 Cross-site scripting (XSS) vulnerability in feedparser.py in Universal Feed Parser (aka… CVSS 2.0MEDIUM 4.3
- TI-2011-01009 Cross-site scripting (XSS) vulnerability in feedparser.py in Universal Feed Parser (aka… CVSS 2.0MEDIUM 4.3
Sources
- CVE-2009-5065 · CVE Program
- CVE-2009-5065 · NVD
- FIRST EPSS
- GHSA-3mwg-gp5g-fv3q · GitHub Advisory Database · CC BY 4.0
- CVE-2009-5065 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences