Cross-site scripting (XSS) vulnerability in feedparser.py in Universal Feed Parser (aka…
Priority LOW 25CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in feedparser.py in Universal Feed Parser (aka feedparser or python-feedparser) 5.x before 5.0.1 allows remote attackers to inject arbitrary web script or HTML via an unexpected URI scheme, as demonstrated by a javascript: URI.
Why it matters now
EPSS 0.02346 83rd percentileScored 2026-11-07
Fix Fixed feedparser (PyPI): 5.0.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | feedparser (PyPI) | 5.0 to before 5.0.1 | 5.0.1 | Patch available | GHSA-4m72-rmm9-2qjr |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- feedparser (PyPI) Vendor— Affected 5.0 to before 5.0.1 Fixed in 5.0.1 Patch available GHSA-4m72-rmm9-2qjr
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mark_pilgrim:feedparser:5.0:*:*:*:*:*:*:* | 5.0 | Vulnerable | Mark Pilgrim |
- cpe:2.3:a:mark_pilgrim:feedparser:5.0:*:*:*:*:*:*:* Versions 5.0 Vulnerable ·Mark Pilgrim
Remediation
- Fix · GHSA-4m72-rmm9-2qjr feedparser (PyPI) Fixed in 5.0.1 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2011-1158
- 2026-10-03 Alias added: GHSA-4m72-rmm9-2qjr
References
Patch 3
Advisory 3
Other 7
- http://support.novell.com/security/cve/CVE-2011-1158.html
- https://code.google.com/p/feedparser/issues/detail?id=255
- [oss-security] 20110315 Re: CVE request for python-feedparser
- [opensuse-updates] 20110408 openSUSE-SU-2011:0314-1 (moderate): python-feedparser security update
- https://github.com/pypa/advisory-database/tree/main/vulns/feedparser/PYSEC-2011-21.yaml
- https://web.archive.org/web/20150523054015/http://www.mandriva.com/en/support/security/advisories/advisory/MDVSA-2011:082/?name=MDVSA-2011:082
- https://web.archive.org/web/20210121212051/https://www.securityfocus.com/bid/46867
More Mark Pilgrim Feedparser vulnerabilities
- TI-2011-01008 feedparser.py in Universal Feed Parser (aka feedparser or python-feedparser) before 5.0.1… CVSS 2.0MEDIUM 5.0
- TI-2012-02535 Universal Feed Parser (aka feedparser or python-feedparser) before 5.1.2 allows remote… CVSS 2.0MEDIUM 5.0
- TI-2009-04819 Cross-site scripting (XSS) vulnerability in feedparser.py in Universal Feed Parser (aka… CVSS 2.0MEDIUM 4.3
- TI-2011-01009 Cross-site scripting (XSS) vulnerability in feedparser.py in Universal Feed Parser (aka… CVSS 2.0MEDIUM 4.3
Sources
- CVE-2011-1158 · CVE Program
- CVE-2011-1158 · NVD
- FIRST EPSS
- GHSA-4m72-rmm9-2qjr · GitHub Advisory Database · CC BY 4.0
- CVE-2011-1158 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences