feedparser.py in Universal Feed Parser (aka feedparser or python-feedparser) before 5.0.1…
Priority LOW 29CWE-399Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-399 and the CVSS impact.
Summary
feedparser.py in Universal Feed Parser (aka feedparser or python-feedparser) before 5.0.1 allows remote attackers to cause a denial of service (application crash) via a malformed DOCTYPE declaration.
Why it matters now
EPSS 0.03261 88th percentileScored 2026-11-07
Public exploit Yes 3 exploit referencesTagged by NVD
Fix Fixed feedparser (PyPI): 5.0.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | feedparser (PyPI) | 4.1 to before 5.0.1 | 5.0.1 | Patch available | GHSA-6h52-4vmh-8x4f |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- feedparser (PyPI) Vendor— Affected 4.1 to before 5.0.1 Fixed in 5.0.1 Patch available GHSA-6h52-4vmh-8x4f
CPE configurations NVD · 10
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mark_pilgrim:feedparser:*:*:*:*:*:*:*:* | up to 5.0 | Vulnerable | Mark Pilgrim |
| cpe:2.3:a:mark_pilgrim:feedparser:3.0:*:*:*:*:*:*:* | 3.0 | Vulnerable | Mark Pilgrim |
| cpe:2.3:a:mark_pilgrim:feedparser:3.0.1:*:*:*:*:*:*:* | 3.0.1 | Vulnerable | Mark Pilgrim |
| cpe:2.3:a:mark_pilgrim:feedparser:3.1:*:*:*:*:*:*:* | 3.1 | Vulnerable | Mark Pilgrim |
| cpe:2.3:a:mark_pilgrim:feedparser:3.2:*:*:*:*:*:*:* | 3.2 | Vulnerable | Mark Pilgrim |
| cpe:2.3:a:mark_pilgrim:feedparser:3.3:*:*:*:*:*:*:* | 3.3 | Vulnerable | Mark Pilgrim |
| cpe:2.3:a:mark_pilgrim:feedparser:4.0:*:*:*:*:*:*:* | 4.0 | Vulnerable | Mark Pilgrim |
| cpe:2.3:a:mark_pilgrim:feedparser:4.0.1:*:*:*:*:*:*:* | 4.0.1 | Vulnerable | Mark Pilgrim |
| cpe:2.3:a:mark_pilgrim:feedparser:4.0.2:*:*:*:*:*:*:* | 4.0.2 | Vulnerable | Mark Pilgrim |
| cpe:2.3:a:mark_pilgrim:feedparser:4.1:*:*:*:*:*:*:* | 4.1 | Vulnerable | Mark Pilgrim |
- cpe:2.3:a:mark_pilgrim:feedparser:*:*:*:*:*:*:*:* Versions up to 5.0 Vulnerable ·Mark Pilgrim
- cpe:2.3:a:mark_pilgrim:feedparser:3.0:*:*:*:*:*:*:* Versions 3.0 Vulnerable ·Mark Pilgrim
- cpe:2.3:a:mark_pilgrim:feedparser:3.0.1:*:*:*:*:*:*:* Versions 3.0.1 Vulnerable ·Mark Pilgrim
- cpe:2.3:a:mark_pilgrim:feedparser:3.1:*:*:*:*:*:*:* Versions 3.1 Vulnerable ·Mark Pilgrim
- cpe:2.3:a:mark_pilgrim:feedparser:3.2:*:*:*:*:*:*:* Versions 3.2 Vulnerable ·Mark Pilgrim
- cpe:2.3:a:mark_pilgrim:feedparser:3.3:*:*:*:*:*:*:* Versions 3.3 Vulnerable ·Mark Pilgrim
- cpe:2.3:a:mark_pilgrim:feedparser:4.0:*:*:*:*:*:*:* Versions 4.0 Vulnerable ·Mark Pilgrim
- cpe:2.3:a:mark_pilgrim:feedparser:4.0.1:*:*:*:*:*:*:* Versions 4.0.1 Vulnerable ·Mark Pilgrim
- cpe:2.3:a:mark_pilgrim:feedparser:4.0.2:*:*:*:*:*:*:* Versions 4.0.2 Vulnerable ·Mark Pilgrim
- cpe:2.3:a:mark_pilgrim:feedparser:4.1:*:*:*:*:*:*:* Versions 4.1 Vulnerable ·Mark Pilgrim
Remediation
- Fix · GHSA-6h52-4vmh-8x4f feedparser (PyPI) Fixed in 5.0.1 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2011-1156
- 2026-10-03 Alias added: GHSA-6h52-4vmh-8x4f
References
Exploit 3
Advisory 3
Other 6
- http://support.novell.com/security/cve/CVE-2011-1156.html
- https://bugzilla.redhat.com/show_bug.cgi?id=684877
- [opensuse-updates] 20110408 openSUSE-SU-2011:0314-1 (moderate): python-feedparser security update
- https://github.com/pypa/advisory-database/tree/main/vulns/feedparser/PYSEC-2011-19.yaml
- https://web.archive.org/web/20150523054015/http://www.mandriva.com/en/support/security/advisories/advisory/MDVSA-2011:082/?name=MDVSA-2011:082
- https://web.archive.org/web/20210121212051/https://www.securityfocus.com/bid/46867
More Mark Pilgrim Feedparser vulnerabilities
- TI-2012-02535 Universal Feed Parser (aka feedparser or python-feedparser) before 5.1.2 allows remote… CVSS 2.0MEDIUM 5.0
- TI-2009-04819 Cross-site scripting (XSS) vulnerability in feedparser.py in Universal Feed Parser (aka… CVSS 2.0MEDIUM 4.3
- TI-2011-01010 Cross-site scripting (XSS) vulnerability in feedparser.py in Universal Feed Parser (aka… CVSS 2.0MEDIUM 4.3
- TI-2011-01009 Cross-site scripting (XSS) vulnerability in feedparser.py in Universal Feed Parser (aka… CVSS 2.0MEDIUM 4.3
Sources
- CVE-2011-1156 · CVE Program
- CVE-2011-1156 · NVD
- FIRST EPSS
- GHSA-6h52-4vmh-8x4f · GitHub Advisory Database · CC BY 4.0
- CVE-2011-1156 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences