Universal Feed Parser (aka feedparser or python-feedparser) before 5.1.2 allows remote…
Priority LOW 28CWE-399Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-399 and the CVSS impact.
Summary
Universal Feed Parser (aka feedparser or python-feedparser) before 5.1.2 allows remote attackers to cause a denial of service (memory consumption) via a crafted XML ENTITY declaration in a non-ASCII encoded document.
Why it matters now
EPSS 0.02744 86th percentileScored 2026-11-07
Fix Fixed feedparser (PyPI): 5.1.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | feedparser (PyPI) | before 5.1.2 | 5.1.2 | Patch available | GHSA-hjf3-r7gw-9rwg |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- feedparser (PyPI) Vendor— Affected before 5.1.2 Fixed in 5.1.2 Patch available GHSA-hjf3-r7gw-9rwg
CPE configurations NVD · 14
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mark_pilgrim:feedparser:*:*:*:*:*:*:*:* | up to 5.1.1 | Vulnerable | Mark Pilgrim |
| cpe:2.3:a:mark_pilgrim:feedparser:3.0:*:*:*:*:*:*:* | 3.0 | Vulnerable | Mark Pilgrim |
| cpe:2.3:a:mark_pilgrim:feedparser:3.0.1:*:*:*:*:*:*:* | 3.0.1 | Vulnerable | Mark Pilgrim |
| cpe:2.3:a:mark_pilgrim:feedparser:3.1:*:*:*:*:*:*:* | 3.1 | Vulnerable | Mark Pilgrim |
| cpe:2.3:a:mark_pilgrim:feedparser:3.2:*:*:*:*:*:*:* | 3.2 | Vulnerable | Mark Pilgrim |
| cpe:2.3:a:mark_pilgrim:feedparser:3.3:*:*:*:*:*:*:* | 3.3 | Vulnerable | Mark Pilgrim |
| cpe:2.3:a:mark_pilgrim:feedparser:4.0:*:*:*:*:*:*:* | 4.0 | Vulnerable | Mark Pilgrim |
| cpe:2.3:a:mark_pilgrim:feedparser:4.0.1:*:*:*:*:*:*:* | 4.0.1 | Vulnerable | Mark Pilgrim |
| cpe:2.3:a:mark_pilgrim:feedparser:4.0.2:*:*:*:*:*:*:* | 4.0.2 | Vulnerable | Mark Pilgrim |
| cpe:2.3:a:mark_pilgrim:feedparser:4.1:*:*:*:*:*:*:* | 4.1 | Vulnerable | Mark Pilgrim |
- cpe:2.3:a:mark_pilgrim:feedparser:*:*:*:*:*:*:*:* Versions up to 5.1.1 Vulnerable ·Mark Pilgrim
- cpe:2.3:a:mark_pilgrim:feedparser:3.0:*:*:*:*:*:*:* Versions 3.0 Vulnerable ·Mark Pilgrim
- cpe:2.3:a:mark_pilgrim:feedparser:3.0.1:*:*:*:*:*:*:* Versions 3.0.1 Vulnerable ·Mark Pilgrim
- cpe:2.3:a:mark_pilgrim:feedparser:3.1:*:*:*:*:*:*:* Versions 3.1 Vulnerable ·Mark Pilgrim
- cpe:2.3:a:mark_pilgrim:feedparser:3.2:*:*:*:*:*:*:* Versions 3.2 Vulnerable ·Mark Pilgrim
- cpe:2.3:a:mark_pilgrim:feedparser:3.3:*:*:*:*:*:*:* Versions 3.3 Vulnerable ·Mark Pilgrim
- cpe:2.3:a:mark_pilgrim:feedparser:4.0:*:*:*:*:*:*:* Versions 4.0 Vulnerable ·Mark Pilgrim
- cpe:2.3:a:mark_pilgrim:feedparser:4.0.1:*:*:*:*:*:*:* Versions 4.0.1 Vulnerable ·Mark Pilgrim
- cpe:2.3:a:mark_pilgrim:feedparser:4.0.2:*:*:*:*:*:*:* Versions 4.0.2 Vulnerable ·Mark Pilgrim
- cpe:2.3:a:mark_pilgrim:feedparser:4.1:*:*:*:*:*:*:* Versions 4.1 Vulnerable ·Mark Pilgrim
Show 4 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mark_pilgrim:feedparser:5.0:*:*:*:*:*:*:* | 5.0 | Vulnerable | Mark Pilgrim |
| cpe:2.3:a:mark_pilgrim:feedparser:5.0.1:*:*:*:*:*:*:* | 5.0.1 | Vulnerable | Mark Pilgrim |
| cpe:2.3:a:mark_pilgrim:feedparser:5.1:*:*:*:*:*:*:* | 5.1 | Vulnerable | Mark Pilgrim |
| cpe:2.3:a:mark_pilgrim:feedparser:5.1.2:*:*:*:*:*:*:* | 5.1.2 | Vulnerable | Mark Pilgrim |
- cpe:2.3:a:mark_pilgrim:feedparser:5.0:*:*:*:*:*:*:* Versions 5.0 Vulnerable ·Mark Pilgrim
- cpe:2.3:a:mark_pilgrim:feedparser:5.0.1:*:*:*:*:*:*:* Versions 5.0.1 Vulnerable ·Mark Pilgrim
- cpe:2.3:a:mark_pilgrim:feedparser:5.1:*:*:*:*:*:*:* Versions 5.1 Vulnerable ·Mark Pilgrim
- cpe:2.3:a:mark_pilgrim:feedparser:5.1.2:*:*:*:*:*:*:* Versions 5.1.2 Vulnerable ·Mark Pilgrim
Remediation
- Fix · GHSA-hjf3-r7gw-9rwg feedparser (PyPI) Fixed in 5.1.2 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2012-2921
- 2026-10-03 Alias added: GHSA-hjf3-r7gw-9rwg
References
Advisory 3
Other 9
- 81701
- https://code.google.com/p/feedparser/source/browse/trunk/NEWS?spec=svn706&r=706
- https://wiki.mageia.org/en/Support/Advisories/MGASA-2012-0157
- https://code.google.com/p/feedparser/source/detail?r=703&path=/trunk/feedparser/feedparser.py
- http://freecode.com/projects/feedparser/releases/344371
- https://github.com/kurtmckee/feedparser
- https://github.com/pypa/advisory-database/tree/main/vulns/feedparser/PYSEC-2012-14.yaml
- https://web.archive.org/web/20120604210617/http://www.securityfocus.com/bid/53654
- https://web.archive.org/web/20150523060531/http://www.mandriva.com/en/support/security/advisories/advisory/MDVSA-2013:118/?name=MDVSA-2013:118
More Mark Pilgrim Feedparser vulnerabilities
- TI-2011-01008 feedparser.py in Universal Feed Parser (aka feedparser or python-feedparser) before 5.0.1… CVSS 2.0MEDIUM 5.0
- TI-2009-04819 Cross-site scripting (XSS) vulnerability in feedparser.py in Universal Feed Parser (aka… CVSS 2.0MEDIUM 4.3
- TI-2011-01010 Cross-site scripting (XSS) vulnerability in feedparser.py in Universal Feed Parser (aka… CVSS 2.0MEDIUM 4.3
- TI-2011-01009 Cross-site scripting (XSS) vulnerability in feedparser.py in Universal Feed Parser (aka… CVSS 2.0MEDIUM 4.3
Sources
- CVE-2012-2921 · CVE Program
- CVE-2012-2921 · NVD
- FIRST EPSS
- GHSA-hjf3-r7gw-9rwg · GitHub Advisory Database · CC BY 4.0
- CVE-2012-2921 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences