Puppet 0.24.x before 0.24.9 and 0.25.x before 0.25.2 allows local users to overwrite…
Priority LOW 16CWE-59Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- —
- Confidentiality · integrity · availability
- None · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub.
Summary
Puppet 0.24.x before 0.24.9 and 0.25.x before 0.25.2 allows local users to overwrite arbitrary files via a symlink attack on the (1) /tmp/daemonout, (2) /tmp/puppetdoc.txt, (3) /tmp/puppetdoc.tex, or (4) /tmp/puppetdoc.aux temporary file.
Why it matters now
EPSS 0.00325 25th percentileScored 2026-11-07
Fix Fixed puppet (RubyGems): 0.24.9, 0.25.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | puppet (RubyGems) | 0.24.0 to before 0.24.9 | 0.24.9 | Patch available | GHSA-vrh7-99jh-3fmm |
| — | puppet (RubyGems) | 0.25.0 to before 0.25.2 | 0.25.2 | Patch available | GHSA-vrh7-99jh-3fmm |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- puppet (RubyGems) Vendor— Affected 0.24.0 to before 0.24.9 Fixed in 0.24.9 Patch available GHSA-vrh7-99jh-3fmm
- puppet (RubyGems) Vendor— Affected 0.25.0 to before 0.25.2 Fixed in 0.25.2 Patch available GHSA-vrh7-99jh-3fmm
CPE configurations NVD · 20
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:puppet:puppet:0.24.3:*:*:*:*:*:*:* | 0.24.3 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet:0.24.4:*:*:*:*:*:*:* | 0.24.4 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet:0.24.5:*:*:*:*:*:*:* | 0.24.5 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet:0.24.6:*:*:*:*:*:*:* | 0.24.6 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet:0.24.6:rc1:*:*:*:*:*:* | 0.24.6 rc1 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet:0.24.6:rc2:*:*:*:*:*:* | 0.24.6 rc2 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet:0.24.7:*:*:*:*:*:*:* | 0.24.7 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet:0.24.7:rc2:*:*:*:*:*:* | 0.24.7 rc2 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet:0.24.8:*:*:*:*:*:*:* | 0.24.8 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet:0.24.8:rc1:*:*:*:*:*:* | 0.24.8 rc1 | Vulnerable | Puppet |
- cpe:2.3:a:puppet:puppet:0.24.3:*:*:*:*:*:*:* Versions 0.24.3 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet:0.24.4:*:*:*:*:*:*:* Versions 0.24.4 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet:0.24.5:*:*:*:*:*:*:* Versions 0.24.5 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet:0.24.6:*:*:*:*:*:*:* Versions 0.24.6 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet:0.24.6:rc1:*:*:*:*:*:* Versions 0.24.6 rc1 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet:0.24.6:rc2:*:*:*:*:*:* Versions 0.24.6 rc2 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet:0.24.7:*:*:*:*:*:*:* Versions 0.24.7 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet:0.24.7:rc2:*:*:*:*:*:* Versions 0.24.7 rc2 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet:0.24.8:*:*:*:*:*:*:* Versions 0.24.8 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet:0.24.8:rc1:*:*:*:*:*:* Versions 0.24.8 rc1 Vulnerable ·Puppet
Show 10 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:puppet:puppet:0.25.0:*:*:*:*:*:*:* | 0.25.0 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet:0.25.0:beta1:*:*:*:*:*:* | 0.25.0 beta1 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet:0.25.0:beta2:*:*:*:*:*:* | 0.25.0 beta2 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet:0.25.0:rc1:*:*:*:*:*:* | 0.25.0 rc1 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet:0.25.1:*:*:*:*:*:*:* | 0.25.1 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet:0.25.1:rc1:*:*:*:*:*:* | 0.25.1 rc1 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet:0.25.1:rc2:*:*:*:*:*:* | 0.25.1 rc2 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet:0.25.2:rc1:*:*:*:*:*:* | 0.25.2 rc1 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet:0.25.2:rc2:*:*:*:*:*:* | 0.25.2 rc2 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet:0.25.2:rc3:*:*:*:*:*:* | 0.25.2 rc3 | Vulnerable | Puppet |
- cpe:2.3:a:puppet:puppet:0.25.0:*:*:*:*:*:*:* Versions 0.25.0 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet:0.25.0:beta1:*:*:*:*:*:* Versions 0.25.0 beta1 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet:0.25.0:beta2:*:*:*:*:*:* Versions 0.25.0 beta2 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet:0.25.0:rc1:*:*:*:*:*:* Versions 0.25.0 rc1 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet:0.25.1:*:*:*:*:*:*:* Versions 0.25.1 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet:0.25.1:rc1:*:*:*:*:*:* Versions 0.25.1 rc1 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet:0.25.1:rc2:*:*:*:*:*:* Versions 0.25.1 rc2 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet:0.25.2:rc1:*:*:*:*:*:* Versions 0.25.2 rc1 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet:0.25.2:rc2:*:*:*:*:*:* Versions 0.25.2 rc2 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet:0.25.2:rc3:*:*:*:*:*:* Versions 0.25.2 rc3 Vulnerable ·Puppet
Remediation
- Fix · GHSA-vrh7-99jh-3fmm puppet (RubyGems) Fixed in 0.24.9 Advisory →
- Fix · GHSA-vrh7-99jh-3fmm puppet (RubyGems) Fixed in 0.25.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2010-0156
- 2026-10-03 Alias added: GHSA-vrh7-99jh-3fmm
References
Patch 2
Advisory 4
Other 7
- [puppet-announce] 20100108 ANNOUNCE: Puppet 0.24.9 is available
- https://puppet.com/security/cve/cve-2010-0156
- https://github.com/puppetlabs/puppet/commit/0aae57f91dc69b22fb674f8de3a13c22edd07128
- https://github.com/puppetlabs/puppet/commit/6111ba80f2c6f6d1541af971f565119e6e03d77d
- https://github.com/puppetlabs/puppet
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/puppet/CVE-2010-0156.yml
- https://web.archive.org/web/20100316113904/http://secunia.com/advisories/38766
More Puppet vulnerabilities
- TI-2016-02327 Puppet Server before 2.3.2 and Ruby puppetmaster in Puppet 4.x before 4.4.2 and in Puppet… CVSS 3.1CRITICAL 9.8
- TI-2013-01442 The (1) template and (2) inline_template functions in the master server in Puppet before… CVSS 2.0HIGH 9.0
- TI-2021-08594 SQL injection in Puppet DB CVSS 3.1HIGH 8.8
- TI-2017-01576 Deserialization of untrusted data in Puppet server CVSS 3.0HIGH 8.2
- TI-2018-04793 Untrusted search path in Puppet Enterprise and Puppet Agent CVSS 3.0HIGH 8.8
- TI-2013-01456 Puppet 2.7.x before 2.7.21 and 3.1.x before 3.1.1, when running Ruby 1.9.3 or later… CVSS 2.0HIGH 7.5
Sources
- CVE-2010-0156 · CVE Program
- CVE-2010-0156 · NVD
- FIRST EPSS
- GHSA-vrh7-99jh-3fmm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences