The set_mgmt_parameters function in item.py in cobbler before 2.2.2 allows…
Priority LOW 34CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Code execution
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
The set_mgmt_parameters function in item.py in cobbler before 2.2.2 allows context-dependent attackers to execute arbitrary code via vectors related to the use of the yaml.load function instead of the yaml.safe_load function, as demonstrated using Puppet.
Why it matters now
EPSS 0.02192 82nd percentileScored 2026-11-07
Fix Fixed cobbler (PyPI): 2.6.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | cobbler (PyPI) | before 2.6.0 | 2.6.0 | Patch available | GHSA-hpj3-5p46-g87w |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- cobbler (PyPI) Vendor— Affected before 2.6.0 Fixed in 2.6.0 Patch available GHSA-hpj3-5p46-g87w
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:cobbler_project:cobbler:*:*:*:*:*:*:*:* | up to 2.2.1 | Vulnerable | The Cobbler Project |
- cpe:2.3:a:cobbler_project:cobbler:*:*:*:*:*:*:*:* Versions up to 2.2.1 Vulnerable ·The Cobbler Project
Remediation
- Fix · GHSA-hpj3-5p46-g87w cobbler (PyPI) Fixed in 2.6.0 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2011-4953
- 2026-10-03 Alias added: GHSA-hpj3-5p46-g87w
References
More The Cobbler Project Cobbler vulnerabilities
- TI-2021-17397 Cobbler before 3.3.0 allows log poisoning, and resultant Remote Code Execution, via an… CVSS 3.1CRITICAL 9.8
- TI-2018-07743 It was found that cobbler 2.6.x exposed all functions from its CobblerXMLRPCInterface… CVSS 3.0CRITICAL 9.8
- TI-2021-17398 Cobbler before 3.3.0 allows arbitrary file write operations via upload_log_data. CVSS 3.1HIGH 7.5
- TI-2017-14678 Cobbler version up to 2.8.2 is vulnerable to a command injection vulnerability in the… CVSS 3.0CRITICAL 9.8
- TI-2022-00766 Improper Authorization in cobbler/cobbler CVSS 3.1CRITICAL 9.1
- TI-2021-17399 Cobbler before 3.3.0 allows authorization bypass for modification of settings. CVSS 3.1HIGH 7.5
Sources
- CVE-2011-4953 · CVE Program
- CVE-2011-4953 · NVD
- FIRST EPSS
- GHSA-hpj3-5p46-g87w · GitHub Advisory Database · CC BY 4.0
- CVE-2011-4953 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences