The (1) Zend_Feed_Rss and (2) Zend_Feed_Atom classes in Zend_Feed in Zend Framework…
Priority LOW 26CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Partial · None · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
The (1) Zend_Feed_Rss and (2) Zend_Feed_Atom classes in Zend_Feed in Zend Framework 1.11.x before 1.11.15 and 1.12.x before 1.12.1 allow remote attackers to read arbitrary files, send HTTP requests to intranet servers, and possibly cause a denial of service (CPU and memory consumption) via an XML External Entity (XXE) attack.
Why it matters now
EPSS 0.01705 77th percentileScored 2026-11-07
Fix Fixed zendframework/zendframework1 (Packagist): 1.11.15, 1.12.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | zendframework/zendframework1 (Packagist) | before 1.11.15 | 1.11.15 | Patch available | GHSA-9m5v-vq4f-mrvf |
| — | zendframework/zendframework1 (Packagist) | 1.12.0-rc1 to before 1.12.1 | 1.12.1 | Patch available | GHSA-9m5v-vq4f-mrvf |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- zendframework/zendframework1 (Packagist) Vendor— Affected before 1.11.15 Fixed in 1.11.15 Patch available GHSA-9m5v-vq4f-mrvf
- zendframework/zendframework1 (Packagist) Vendor— Affected 1.12.0-rc1 to before 1.12.1 Fixed in 1.12.1 Patch available GHSA-9m5v-vq4f-mrvf
CPE configurations NVD · 15
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:zend:zend_framework:1.11.0:*:*:*:*:*:*:* | 1.11.0 | Vulnerable | Zend |
| cpe:2.3:a:zend:zend_framework:1.11.1:*:*:*:*:*:*:* | 1.11.1 | Vulnerable | Zend |
| cpe:2.3:a:zend:zend_framework:1.11.2:*:*:*:*:*:*:* | 1.11.2 | Vulnerable | Zend |
| cpe:2.3:a:zend:zend_framework:1.11.3:*:*:*:*:*:*:* | 1.11.3 | Vulnerable | Zend |
| cpe:2.3:a:zend:zend_framework:1.11.4:*:*:*:*:*:*:* | 1.11.4 | Vulnerable | Zend |
| cpe:2.3:a:zend:zend_framework:1.11.5:*:*:*:*:*:*:* | 1.11.5 | Vulnerable | Zend |
| cpe:2.3:a:zend:zend_framework:1.11.6:*:*:*:*:*:*:* | 1.11.6 | Vulnerable | Zend |
| cpe:2.3:a:zend:zend_framework:1.11.7:*:*:*:*:*:*:* | 1.11.7 | Vulnerable | Zend |
| cpe:2.3:a:zend:zend_framework:1.11.8:*:*:*:*:*:*:* | 1.11.8 | Vulnerable | Zend |
| cpe:2.3:a:zend:zend_framework:1.11.9:*:*:*:*:*:*:* | 1.11.9 | Vulnerable | Zend |
- cpe:2.3:a:zend:zend_framework:1.11.0:*:*:*:*:*:*:* Versions 1.11.0 Vulnerable ·Zend
- cpe:2.3:a:zend:zend_framework:1.11.1:*:*:*:*:*:*:* Versions 1.11.1 Vulnerable ·Zend
- cpe:2.3:a:zend:zend_framework:1.11.2:*:*:*:*:*:*:* Versions 1.11.2 Vulnerable ·Zend
- cpe:2.3:a:zend:zend_framework:1.11.3:*:*:*:*:*:*:* Versions 1.11.3 Vulnerable ·Zend
- cpe:2.3:a:zend:zend_framework:1.11.4:*:*:*:*:*:*:* Versions 1.11.4 Vulnerable ·Zend
- cpe:2.3:a:zend:zend_framework:1.11.5:*:*:*:*:*:*:* Versions 1.11.5 Vulnerable ·Zend
- cpe:2.3:a:zend:zend_framework:1.11.6:*:*:*:*:*:*:* Versions 1.11.6 Vulnerable ·Zend
- cpe:2.3:a:zend:zend_framework:1.11.7:*:*:*:*:*:*:* Versions 1.11.7 Vulnerable ·Zend
- cpe:2.3:a:zend:zend_framework:1.11.8:*:*:*:*:*:*:* Versions 1.11.8 Vulnerable ·Zend
- cpe:2.3:a:zend:zend_framework:1.11.9:*:*:*:*:*:*:* Versions 1.11.9 Vulnerable ·Zend
Show 5 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:zend:zend_framework:1.11.10:*:*:*:*:*:*:* | 1.11.10 | Vulnerable | Zend |
| cpe:2.3:a:zend:zend_framework:1.11.11:*:*:*:*:*:*:* | 1.11.11 | Vulnerable | Zend |
| cpe:2.3:a:zend:zend_framework:1.11.12:*:*:*:*:*:*:* | 1.11.12 | Vulnerable | Zend |
| cpe:2.3:a:zend:zend_framework:1.11.13:*:*:*:*:*:*:* | 1.11.13 | Vulnerable | Zend |
| cpe:2.3:a:zend:zend_framework:1.12.0:*:*:*:*:*:*:* | 1.12.0 | Vulnerable | Zend |
- cpe:2.3:a:zend:zend_framework:1.11.10:*:*:*:*:*:*:* Versions 1.11.10 Vulnerable ·Zend
- cpe:2.3:a:zend:zend_framework:1.11.11:*:*:*:*:*:*:* Versions 1.11.11 Vulnerable ·Zend
- cpe:2.3:a:zend:zend_framework:1.11.12:*:*:*:*:*:*:* Versions 1.11.12 Vulnerable ·Zend
- cpe:2.3:a:zend:zend_framework:1.11.13:*:*:*:*:*:*:* Versions 1.11.13 Vulnerable ·Zend
- cpe:2.3:a:zend:zend_framework:1.12.0:*:*:*:*:*:*:* Versions 1.12.0 Vulnerable ·Zend
Remediation
- Fix · GHSA-9m5v-vq4f-mrvf zendframework/zendframework1 (Packagist) Fixed in 1.11.15 Advisory →
- Fix · GHSA-9m5v-vq4f-mrvf zendframework/zendframework1 (Packagist) Fixed in 1.12.1 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2012-5657
- 2026-10-03 Alias added: GHSA-9m5v-vq4f-mrvf
References
Advisory 4
Other 5
- [oss-security] 20121219 CVE request: information disclosure flaw in php-ZendFramework (ZF2012-05)
- [oss-security] 20121219 Re: CVE request: information disclosure flaw in php-ZendFramework (ZF2012-05)
- https://github.com/zendframework/zf1/commit/15c84914f063efea49ea1c4425459a792cc185ea
- https://github.com/zendframework/zf1
- https://web.archive.org/web/20131101014013/http://www.mandriva.com/en/support/security/advisories/advisory/MDVSA-2013:115/?name=MDVSA-2013:115
More Zend Framework vulnerabilities
- TI-2021-02150 Laminas Project laminas-http before 2.14.2, and Zend Framework 3.0.0, has a… CVSS 3.1CRITICAL 9.8
- TI-2012-02894 Zend_XmlRpc in Zend Framework 1.x before 1.11.12 and 1.12.x before 1.12.0 does not… CVSS 3.1CRITICAL 9.1
- TI-2016-08119 The setFrom function in the Sendmail adapter in the zend-mail component before 2.4.11… CVSS 3.0CRITICAL 9.8
- TI-2020-17638 An issue found in Zend Framework v.3.1.3 and before allow a remote attacker to execute… CVSS 3.1CRITICAL 9.8
- TI-2016-04204 The (1) order and (2) group methods in Zend_Db_Select in the Zend Framework before… CVSS 3.0CRITICAL 9.8
- TI-2011-01711 SQL injection in zendframework;PHP zendframework CVSS 3.1CRITICAL 9.8
Sources
- CVE-2012-5657 · CVE Program
- CVE-2012-5657 · NVD
- FIRST EPSS
- GHSA-9m5v-vq4f-mrvf · GitHub Advisory Database · CC BY 4.0
- CVE-2012-5657 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences