Zend Framework 1 (ZF1) before 1.12.4, Zend Framework 2 before 2.1.6 and 2.2.x before…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-611 and the CVSS impact.
Summary
Zend Framework 1 (ZF1) before 1.12.4, Zend Framework 2 before 2.1.6 and 2.2.x before 2.2.6, ZendOpenId, ZendRest, ZendService_AudioScrobbler, ZendService_Nirvanix, ZendService_SlideShare, ZendService_Technorati, and ZendService_WindowsAzure before 2.0.2, ZendService_Amazon before 2.0.3, and ZendService_Api before 1.0.0 allow remote attackers to cause a denial of service (CPU consumption) via (1) recursive or (2) circular references in an XML entity definition in an XML DOCTYPE declaration, aka an XML Entity Expansion (XEE) attack. NOTE: this issue exists because of an incomplete fix for CVE-2012-6532.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | zendframework/zendframework1 (Packagist) | before 1.12.4 | 1.12.4 | Patch available | GHSA-5wm2-38q5-5rxv |
| — | zendframework/zendopenid (Packagist) | before 2.0.2 | 2.0.2 | Patch available | GHSA-5wm2-38q5-5rxv |
| — | zendframework/zendrest (Packagist) | before 2.0.2 | 2.0.2 | Patch available | GHSA-5wm2-38q5-5rxv |
| — | zendframework/zendservice-audioscrobbler (Packagist) | before 2.0.2 | 2.0.2 | Patch available | GHSA-5wm2-38q5-5rxv |
| — | zendframework/zendservice-nirvanix (Packagist) | before 2.0.2 | 2.0.2 | Patch available | GHSA-5wm2-38q5-5rxv |
| — | zendframework/zendservice-slideshare (Packagist) | before 2.0.2 | 2.0.2 | Patch available | GHSA-5wm2-38q5-5rxv |
| — | zendframework/zendservice-technorati (Packagist) | before 2.0.2 | 2.0.2 | Patch available | GHSA-5wm2-38q5-5rxv |
| — | zendframework/zendservice-windowsazure (Packagist) | before 2.0.2 | 2.0.2 | Patch available | GHSA-5wm2-38q5-5rxv |
| — | zendframework/zendservice-amazon (Packagist) | before 2.0.3 | 2.0.3 | Patch available | GHSA-5wm2-38q5-5rxv |
| — | zendframework/zendservice-api (Packagist) | before 1.0.0 | 1.0.0 | Patch available | GHSA-5wm2-38q5-5rxv |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- zendframework/zendframework1 (Packagist) Vendor— Affected before 1.12.4 Fixed in 1.12.4 Patch available GHSA-5wm2-38q5-5rxv
- zendframework/zendopenid (Packagist) Vendor— Affected before 2.0.2 Fixed in 2.0.2 Patch available GHSA-5wm2-38q5-5rxv
- zendframework/zendrest (Packagist) Vendor— Affected before 2.0.2 Fixed in 2.0.2 Patch available GHSA-5wm2-38q5-5rxv
- zendframework/zendservice-audioscrobbler (Packagist) Vendor— Affected before 2.0.2 Fixed in 2.0.2 Patch available GHSA-5wm2-38q5-5rxv
- zendframework/zendservice-nirvanix (Packagist) Vendor— Affected before 2.0.2 Fixed in 2.0.2 Patch available GHSA-5wm2-38q5-5rxv
- zendframework/zendservice-slideshare (Packagist) Vendor— Affected before 2.0.2 Fixed in 2.0.2 Patch available GHSA-5wm2-38q5-5rxv
- zendframework/zendservice-technorati (Packagist) Vendor— Affected before 2.0.2 Fixed in 2.0.2 Patch available GHSA-5wm2-38q5-5rxv
- zendframework/zendservice-windowsazure (Packagist) Vendor— Affected before 2.0.2 Fixed in 2.0.2 Patch available GHSA-5wm2-38q5-5rxv
- zendframework/zendservice-amazon (Packagist) Vendor— Affected before 2.0.3 Fixed in 2.0.3 Patch available GHSA-5wm2-38q5-5rxv
- zendframework/zendservice-api (Packagist) Vendor— Affected before 1.0.0 Fixed in 1.0.0 Patch available GHSA-5wm2-38q5-5rxv
CPE configurations NVD · 10
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:zend:zendrest:*:*:*:*:*:*:*:* | up to 2.0.1 | Vulnerable | Zend |
| cpe:2.3:a:zend:zend_framework:*:*:*:*:*:*:*:* | before 1.12.4; 2.1.0 to before 2.1.6; 2.2.0 to before 2.2.6 | Vulnerable | Zend |
| cpe:2.3:a:zend:zendservice_slideshare:*:*:*:*:*:*:*:* | up to 2.0.1 | Vulnerable | Zend |
| cpe:2.3:a:zend:zendservice_api:*:*:*:*:*:*:*:* | up to 1.0.0 | Vulnerable | Zend |
| cpe:2.3:a:zend:zendservice_audioscrobbler:*:*:*:*:*:*:*:* | up to 2.0.1 | Vulnerable | Zend |
| cpe:2.3:a:zend:zendservice_amazon:*:*:*:*:*:*:*:* | up to 2.0.2 | Vulnerable | Zend |
| cpe:2.3:a:zend:zendservice_technorati:*:*:*:*:*:*:*:* | up to 2.0.1 | Vulnerable | Zend |
| cpe:2.3:a:zend:zendservice_windowsazure:*:*:*:*:*:*:*:* | up to 2.0.1 | Vulnerable | Zend |
| cpe:2.3:a:zend:zendopenid:*:*:*:*:*:*:*:* | up to 2.0.1 | Vulnerable | Zend |
| cpe:2.3:a:zend:zendservice_nirvanix:*:*:*:*:*:*:*:* | up to 2.0.1 | Vulnerable | Zend |
- cpe:2.3:a:zend:zendrest:*:*:*:*:*:*:*:* Versions up to 2.0.1 Vulnerable ·Zend
- cpe:2.3:a:zend:zend_framework:*:*:*:*:*:*:*:* Versions before 1.12.4; 2.1.0 to before 2.1.6; 2.2.0 to before 2.2.6 Vulnerable ·Zend
- cpe:2.3:a:zend:zendservice_slideshare:*:*:*:*:*:*:*:* Versions up to 2.0.1 Vulnerable ·Zend
- cpe:2.3:a:zend:zendservice_api:*:*:*:*:*:*:*:* Versions up to 1.0.0 Vulnerable ·Zend
- cpe:2.3:a:zend:zendservice_audioscrobbler:*:*:*:*:*:*:*:* Versions up to 2.0.1 Vulnerable ·Zend
- cpe:2.3:a:zend:zendservice_amazon:*:*:*:*:*:*:*:* Versions up to 2.0.2 Vulnerable ·Zend
- cpe:2.3:a:zend:zendservice_technorati:*:*:*:*:*:*:*:* Versions up to 2.0.1 Vulnerable ·Zend
- cpe:2.3:a:zend:zendservice_windowsazure:*:*:*:*:*:*:*:* Versions up to 2.0.1 Vulnerable ·Zend
- cpe:2.3:a:zend:zendopenid:*:*:*:*:*:*:*:* Versions up to 2.0.1 Vulnerable ·Zend
- cpe:2.3:a:zend:zendservice_nirvanix:*:*:*:*:*:*:*:* Versions up to 2.0.1 Vulnerable ·Zend
Remediation
- Fix · GHSA-5wm2-38q5-5rxv zendframework/zendframework1 (Packagist) Fixed in 1.12.4 Advisory →
- Fix · GHSA-5wm2-38q5-5rxv zendframework/zendopenid (Packagist) Fixed in 2.0.2 Advisory →
- Fix · GHSA-5wm2-38q5-5rxv zendframework/zendrest (Packagist) Fixed in 2.0.2 Advisory →
- Fix · GHSA-5wm2-38q5-5rxv zendframework/zendservice-audioscrobbler (Packagist) Fixed in 2.0.2 Advisory →
- Fix · GHSA-5wm2-38q5-5rxv zendframework/zendservice-nirvanix (Packagist) Fixed in 2.0.2 Advisory →
- Fix · GHSA-5wm2-38q5-5rxv zendframework/zendservice-slideshare (Packagist) Fixed in 2.0.2 Advisory →
- Fix · GHSA-5wm2-38q5-5rxv zendframework/zendservice-technorati (Packagist) Fixed in 2.0.2 Advisory →
- Fix · GHSA-5wm2-38q5-5rxv zendframework/zendservice-windowsazure (Packagist) Fixed in 2.0.2 Advisory →
- Fix · GHSA-5wm2-38q5-5rxv zendframework/zendservice-amazon (Packagist) Fixed in 2.0.3 Advisory →
- Fix · GHSA-5wm2-38q5-5rxv zendframework/zendservice-api (Packagist) Fixed in 1.0.0 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2014-2683
- 2026-10-03 Alias added: GHSA-5wm2-38q5-5rxv
References
Advisory 6
More Zend Framework vulnerabilities
- TI-2021-02150 Laminas Project laminas-http before 2.14.2, and Zend Framework 3.0.0, has a… CVSS 3.1CRITICAL 9.8
- TI-2012-02894 Zend_XmlRpc in Zend Framework 1.x before 1.11.12 and 1.12.x before 1.12.0 does not… CVSS 3.1CRITICAL 9.1
- TI-2016-08119 The setFrom function in the Sendmail adapter in the zend-mail component before 2.4.11… CVSS 3.0CRITICAL 9.8
- TI-2020-17638 An issue found in Zend Framework v.3.1.3 and before allow a remote attacker to execute… CVSS 3.1CRITICAL 9.8
- TI-2016-04204 The (1) order and (2) group methods in Zend_Db_Select in the Zend Framework before… CVSS 3.0CRITICAL 9.8
- TI-2011-01711 SQL injection in zendframework;PHP zendframework CVSS 3.1CRITICAL 9.8
Sources
- CVE-2014-2683 · CVE Program
- CVE-2014-2683 · NVD
- FIRST EPSS
- GHSA-5wm2-38q5-5rxv · GitHub Advisory Database · CC BY 4.0
- CVE-2014-2683 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences