The CDetailView widget in Yii PHP Framework 1.1.14 allows remote attackers to execute…
Priority LOW 37CWE-94Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
The CDetailView widget in Yii PHP Framework 1.1.14 allows remote attackers to execute arbitrary PHP scripts via vectors related to the value property.
Why it matters now
EPSS 0.02122 81st percentileScored 2026-11-07
Fix Fixed yiisoft/yii (Packagist): 1.1.15
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | yiisoft/yii (Packagist) | 1.1.14 to before 1.1.15 | 1.1.15 | Patch available | GHSA-74qv-rv53-5wcx |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- yiisoft/yii (Packagist) Vendor— Affected 1.1.14 to before 1.1.15 Fixed in 1.1.15 Patch available GHSA-74qv-rv53-5wcx
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:yiiframework:yiiframework:1.1.14:*:*:*:*:*:*:* | 1.1.14 | Vulnerable | Yiiframework |
- cpe:2.3:a:yiiframework:yiiframework:1.1.14:*:*:*:*:*:*:* Versions 1.1.14 Vulnerable ·Yiiframework
Remediation
- Fix · GHSA-74qv-rv53-5wcx yiisoft/yii (Packagist) Fixed in 1.1.15 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2014-4672
- 2026-10-03 Alias added: GHSA-74qv-rv53-5wcx
References
Advisory 2
More Yiiframework vulnerabilities
- TI-2018-04377 In Yii Framework 2.x before 2.0.14, the switchIdentity function in web/User.php did not… CVSS 3.0HIGH 8.8
- TI-2018-04378 In Yii Framework 2.x before 2.0.14, remote attackers could obtain potentially sensitive… CVSS 3.0HIGH 7.5
- TI-2015-03005 Cross-site scripting (XSS) vulnerability in Yii Framework before 2.0.4 allows remote… CVSS 2.0MEDIUM 4.3
Sources
- CVE-2014-4672 · CVE Program
- CVE-2014-4672 · NVD
- FIRST EPSS
- GHSA-74qv-rv53-5wcx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences