Cross-site scripting (XSS) vulnerability in Yii Framework before 2.0.4 allows remote…
Priority LOW 25CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in Yii Framework before 2.0.4 allows remote attackers to inject arbitrary web script or HTML via vectors related to JSON, arrays, and Internet Explorer 6 or 7.
Why it matters now
EPSS 0.02381 83rd percentileScored 2026-11-07
Fix Fixed yiisoft/yii2 (Packagist): 2.0.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | yiisoft/yii2 (Packagist) | before 2.0.4 | 2.0.4 | Patch available | GHSA-w2xx-jp9f-gp8g |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- yiisoft/yii2 (Packagist) Vendor— Affected before 2.0.4 Fixed in 2.0.4 Patch available GHSA-w2xx-jp9f-gp8g
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:yiiframework:yiiframework:*:*:*:*:*:*:*:* | up to 2.0.3 | Vulnerable | Yiiframework |
- cpe:2.3:a:yiiframework:yiiframework:*:*:*:*:*:*:*:* Versions up to 2.0.3 Vulnerable ·Yiiframework
Remediation
- Fix · GHSA-w2xx-jp9f-gp8g yiisoft/yii2 (Packagist) Fixed in 2.0.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2015-3397
- 2026-10-03 Alias added: GHSA-w2xx-jp9f-gp8g
References
Patch 2
More Yiiframework vulnerabilities
- TI-2018-04377 In Yii Framework 2.x before 2.0.14, the switchIdentity function in web/User.php did not… CVSS 3.0HIGH 8.8
- TI-2018-04378 In Yii Framework 2.x before 2.0.14, remote attackers could obtain potentially sensitive… CVSS 3.0HIGH 7.5
- TI-2014-03851 The CDetailView widget in Yii PHP Framework 1.1.14 allows remote attackers to execute… CVSS 2.0HIGH 7.5
Sources
- CVE-2015-3397 · CVE Program
- CVE-2015-3397 · NVD
- FIRST EPSS
- GHSA-w2xx-jp9f-gp8g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences