In Yii Framework 2.x before 2.0.14, remote attackers could obtain potentially sensitive…
Priority LOW 38CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
In Yii Framework 2.x before 2.0.14, remote attackers could obtain potentially sensitive information from exception messages, or exploit reflected XSS on the error handler page in non-debug mode. Related to base/ErrorHandler.php, log/Dispatcher.php, and views/errorHandler/exception.php.
Why it matters now
EPSS 0.02883 86th percentileScored 2026-11-07
Fix Fixed yiisoft/yii2 (Packagist): 2.0.14
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | yiisoft/yii2 (Packagist) | 2.0.0 to before 2.0.14 | 2.0.14 | Patch available | GHSA-8gfq-c54m-3rf6 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- yiisoft/yii2 (Packagist) Vendor— Affected 2.0.0 to before 2.0.14 Fixed in 2.0.14 Patch available GHSA-8gfq-c54m-3rf6
CPE configurations NVD · 20
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:yiiframework:yiiframework:2.0.0:*:*:*:*:*:*:* | 2.0.0 | Vulnerable | Yiiframework |
| cpe:2.3:a:yiiframework:yiiframework:2.0.0:alpha:*:*:*:*:*:* | 2.0.0 alpha | Vulnerable | Yiiframework |
| cpe:2.3:a:yiiframework:yiiframework:2.0.0:beta:*:*:*:*:*:* | 2.0.0 beta | Vulnerable | Yiiframework |
| cpe:2.3:a:yiiframework:yiiframework:2.0.0:rc:*:*:*:*:*:* | 2.0.0 rc | Vulnerable | Yiiframework |
| cpe:2.3:a:yiiframework:yiiframework:2.0.1:*:*:*:*:*:*:* | 2.0.1 | Vulnerable | Yiiframework |
| cpe:2.3:a:yiiframework:yiiframework:2.0.2:*:*:*:*:*:*:* | 2.0.2 | Vulnerable | Yiiframework |
| cpe:2.3:a:yiiframework:yiiframework:2.0.3:*:*:*:*:*:*:* | 2.0.3 | Vulnerable | Yiiframework |
| cpe:2.3:a:yiiframework:yiiframework:2.0.4:*:*:*:*:*:*:* | 2.0.4 | Vulnerable | Yiiframework |
| cpe:2.3:a:yiiframework:yiiframework:2.0.5:*:*:*:*:*:*:* | 2.0.5 | Vulnerable | Yiiframework |
| cpe:2.3:a:yiiframework:yiiframework:2.0.6:*:*:*:*:*:*:* | 2.0.6 | Vulnerable | Yiiframework |
- cpe:2.3:a:yiiframework:yiiframework:2.0.0:*:*:*:*:*:*:* Versions 2.0.0 Vulnerable ·Yiiframework
- cpe:2.3:a:yiiframework:yiiframework:2.0.0:alpha:*:*:*:*:*:* Versions 2.0.0 alpha Vulnerable ·Yiiframework
- cpe:2.3:a:yiiframework:yiiframework:2.0.0:beta:*:*:*:*:*:* Versions 2.0.0 beta Vulnerable ·Yiiframework
- cpe:2.3:a:yiiframework:yiiframework:2.0.0:rc:*:*:*:*:*:* Versions 2.0.0 rc Vulnerable ·Yiiframework
- cpe:2.3:a:yiiframework:yiiframework:2.0.1:*:*:*:*:*:*:* Versions 2.0.1 Vulnerable ·Yiiframework
- cpe:2.3:a:yiiframework:yiiframework:2.0.2:*:*:*:*:*:*:* Versions 2.0.2 Vulnerable ·Yiiframework
- cpe:2.3:a:yiiframework:yiiframework:2.0.3:*:*:*:*:*:*:* Versions 2.0.3 Vulnerable ·Yiiframework
- cpe:2.3:a:yiiframework:yiiframework:2.0.4:*:*:*:*:*:*:* Versions 2.0.4 Vulnerable ·Yiiframework
- cpe:2.3:a:yiiframework:yiiframework:2.0.5:*:*:*:*:*:*:* Versions 2.0.5 Vulnerable ·Yiiframework
- cpe:2.3:a:yiiframework:yiiframework:2.0.6:*:*:*:*:*:*:* Versions 2.0.6 Vulnerable ·Yiiframework
Show 10 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:yiiframework:yiiframework:2.0.7:*:*:*:*:*:*:* | 2.0.7 | Vulnerable | Yiiframework |
| cpe:2.3:a:yiiframework:yiiframework:2.0.8:*:*:*:*:*:*:* | 2.0.8 | Vulnerable | Yiiframework |
| cpe:2.3:a:yiiframework:yiiframework:2.0.9:*:*:*:*:*:*:* | 2.0.9 | Vulnerable | Yiiframework |
| cpe:2.3:a:yiiframework:yiiframework:2.0.10:*:*:*:*:*:*:* | 2.0.10 | Vulnerable | Yiiframework |
| cpe:2.3:a:yiiframework:yiiframework:2.0.11:*:*:*:*:*:*:* | 2.0.11 | Vulnerable | Yiiframework |
| cpe:2.3:a:yiiframework:yiiframework:2.0.11.1:*:*:*:*:*:*:* | 2.0.11.1 | Vulnerable | Yiiframework |
| cpe:2.3:a:yiiframework:yiiframework:2.0.11.2:*:*:*:*:*:*:* | 2.0.11.2 | Vulnerable | Yiiframework |
| cpe:2.3:a:yiiframework:yiiframework:2.0.12:*:*:*:*:*:*:* | 2.0.12 | Vulnerable | Yiiframework |
| cpe:2.3:a:yiiframework:yiiframework:2.0.13:*:*:*:*:*:*:* | 2.0.13 | Vulnerable | Yiiframework |
| cpe:2.3:a:yiiframework:yiiframework:2.0.13.1:*:*:*:*:*:*:* | 2.0.13.1 | Vulnerable | Yiiframework |
- cpe:2.3:a:yiiframework:yiiframework:2.0.7:*:*:*:*:*:*:* Versions 2.0.7 Vulnerable ·Yiiframework
- cpe:2.3:a:yiiframework:yiiframework:2.0.8:*:*:*:*:*:*:* Versions 2.0.8 Vulnerable ·Yiiframework
- cpe:2.3:a:yiiframework:yiiframework:2.0.9:*:*:*:*:*:*:* Versions 2.0.9 Vulnerable ·Yiiframework
- cpe:2.3:a:yiiframework:yiiframework:2.0.10:*:*:*:*:*:*:* Versions 2.0.10 Vulnerable ·Yiiframework
- cpe:2.3:a:yiiframework:yiiframework:2.0.11:*:*:*:*:*:*:* Versions 2.0.11 Vulnerable ·Yiiframework
- cpe:2.3:a:yiiframework:yiiframework:2.0.11.1:*:*:*:*:*:*:* Versions 2.0.11.1 Vulnerable ·Yiiframework
- cpe:2.3:a:yiiframework:yiiframework:2.0.11.2:*:*:*:*:*:*:* Versions 2.0.11.2 Vulnerable ·Yiiframework
- cpe:2.3:a:yiiframework:yiiframework:2.0.12:*:*:*:*:*:*:* Versions 2.0.12 Vulnerable ·Yiiframework
- cpe:2.3:a:yiiframework:yiiframework:2.0.13:*:*:*:*:*:*:* Versions 2.0.13 Vulnerable ·Yiiframework
- cpe:2.3:a:yiiframework:yiiframework:2.0.13.1:*:*:*:*:*:*:* Versions 2.0.13.1 Vulnerable ·Yiiframework
Remediation
- Fix · GHSA-8gfq-c54m-3rf6 yiisoft/yii2 (Packagist) Fixed in 2.0.14 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-6010
- 2026-10-03 Alias added: GHSA-8gfq-c54m-3rf6
References
Other 5
- https://github.com/yiisoft/yii2/commit/6b0be47e0fa9c532e03b07b4369050582fcf5c7a
- https://github.com/yiisoft/yii2/issues/14711
- https://github.com/FriendsOfPHP/security-advisories/blob/master/yiisoft/yii2/CVE-2018-6010.yaml
- https://github.com/yiisoft/yii2-framework
- https://www.yiiframework.com/news/165/yii-2-0-14-is-released
More Yiiframework vulnerabilities
- TI-2018-04377 In Yii Framework 2.x before 2.0.14, the switchIdentity function in web/User.php did not… CVSS 3.0HIGH 8.8
- TI-2014-03851 The CDetailView widget in Yii PHP Framework 1.1.14 allows remote attackers to execute… CVSS 2.0HIGH 7.5
- TI-2015-03005 Cross-site scripting (XSS) vulnerability in Yii Framework before 2.0.4 allows remote… CVSS 2.0MEDIUM 4.3
Sources
- CVE-2018-6010 · CVE Program
- CVE-2018-6010 · NVD
- FIRST EPSS
- GHSA-8gfq-c54m-3rf6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences