In Yii Framework 2.x before 2.0.14, the switchIdentity function in web/User.php did not…
Priority LOW 39CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.
Summary
In Yii Framework 2.x before 2.0.14, the switchIdentity function in web/User.php did not regenerate the CSRF token upon a change of identity.
Why it matters now
EPSS 0.00597 48th percentileScored 2026-11-07
Fix Fixed yiisoft/yii2 (Packagist): 2.0.14yiisoft/yii2-dev (Packagist): 2.0.14
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | yiisoft/yii2 (Packagist) | 2.0 to before 2.0.14 | 2.0.14 | Patch available | GHSA-cwhm-272p-3wj9 |
| — | yiisoft/yii2-dev (Packagist) | 2.0 to before 2.0.14 | 2.0.14 | Patch available | GHSA-cwhm-272p-3wj9 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- yiisoft/yii2 (Packagist) Vendor— Affected 2.0 to before 2.0.14 Fixed in 2.0.14 Patch available GHSA-cwhm-272p-3wj9
- yiisoft/yii2-dev (Packagist) Vendor— Affected 2.0 to before 2.0.14 Fixed in 2.0.14 Patch available GHSA-cwhm-272p-3wj9
CPE configurations NVD · 20
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:yiiframework:yiiframework:2.0.0:*:*:*:*:*:*:* | 2.0.0 | Vulnerable | Yiiframework |
| cpe:2.3:a:yiiframework:yiiframework:2.0.0:alpha:*:*:*:*:*:* | 2.0.0 alpha | Vulnerable | Yiiframework |
| cpe:2.3:a:yiiframework:yiiframework:2.0.0:beta:*:*:*:*:*:* | 2.0.0 beta | Vulnerable | Yiiframework |
| cpe:2.3:a:yiiframework:yiiframework:2.0.0:rc:*:*:*:*:*:* | 2.0.0 rc | Vulnerable | Yiiframework |
| cpe:2.3:a:yiiframework:yiiframework:2.0.1:*:*:*:*:*:*:* | 2.0.1 | Vulnerable | Yiiframework |
| cpe:2.3:a:yiiframework:yiiframework:2.0.2:*:*:*:*:*:*:* | 2.0.2 | Vulnerable | Yiiframework |
| cpe:2.3:a:yiiframework:yiiframework:2.0.3:*:*:*:*:*:*:* | 2.0.3 | Vulnerable | Yiiframework |
| cpe:2.3:a:yiiframework:yiiframework:2.0.4:*:*:*:*:*:*:* | 2.0.4 | Vulnerable | Yiiframework |
| cpe:2.3:a:yiiframework:yiiframework:2.0.5:*:*:*:*:*:*:* | 2.0.5 | Vulnerable | Yiiframework |
| cpe:2.3:a:yiiframework:yiiframework:2.0.6:*:*:*:*:*:*:* | 2.0.6 | Vulnerable | Yiiframework |
- cpe:2.3:a:yiiframework:yiiframework:2.0.0:*:*:*:*:*:*:* Versions 2.0.0 Vulnerable ·Yiiframework
- cpe:2.3:a:yiiframework:yiiframework:2.0.0:alpha:*:*:*:*:*:* Versions 2.0.0 alpha Vulnerable ·Yiiframework
- cpe:2.3:a:yiiframework:yiiframework:2.0.0:beta:*:*:*:*:*:* Versions 2.0.0 beta Vulnerable ·Yiiframework
- cpe:2.3:a:yiiframework:yiiframework:2.0.0:rc:*:*:*:*:*:* Versions 2.0.0 rc Vulnerable ·Yiiframework
- cpe:2.3:a:yiiframework:yiiframework:2.0.1:*:*:*:*:*:*:* Versions 2.0.1 Vulnerable ·Yiiframework
- cpe:2.3:a:yiiframework:yiiframework:2.0.2:*:*:*:*:*:*:* Versions 2.0.2 Vulnerable ·Yiiframework
- cpe:2.3:a:yiiframework:yiiframework:2.0.3:*:*:*:*:*:*:* Versions 2.0.3 Vulnerable ·Yiiframework
- cpe:2.3:a:yiiframework:yiiframework:2.0.4:*:*:*:*:*:*:* Versions 2.0.4 Vulnerable ·Yiiframework
- cpe:2.3:a:yiiframework:yiiframework:2.0.5:*:*:*:*:*:*:* Versions 2.0.5 Vulnerable ·Yiiframework
- cpe:2.3:a:yiiframework:yiiframework:2.0.6:*:*:*:*:*:*:* Versions 2.0.6 Vulnerable ·Yiiframework
Show 10 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:yiiframework:yiiframework:2.0.7:*:*:*:*:*:*:* | 2.0.7 | Vulnerable | Yiiframework |
| cpe:2.3:a:yiiframework:yiiframework:2.0.8:*:*:*:*:*:*:* | 2.0.8 | Vulnerable | Yiiframework |
| cpe:2.3:a:yiiframework:yiiframework:2.0.9:*:*:*:*:*:*:* | 2.0.9 | Vulnerable | Yiiframework |
| cpe:2.3:a:yiiframework:yiiframework:2.0.10:*:*:*:*:*:*:* | 2.0.10 | Vulnerable | Yiiframework |
| cpe:2.3:a:yiiframework:yiiframework:2.0.11:*:*:*:*:*:*:* | 2.0.11 | Vulnerable | Yiiframework |
| cpe:2.3:a:yiiframework:yiiframework:2.0.11.1:*:*:*:*:*:*:* | 2.0.11.1 | Vulnerable | Yiiframework |
| cpe:2.3:a:yiiframework:yiiframework:2.0.11.2:*:*:*:*:*:*:* | 2.0.11.2 | Vulnerable | Yiiframework |
| cpe:2.3:a:yiiframework:yiiframework:2.0.12:*:*:*:*:*:*:* | 2.0.12 | Vulnerable | Yiiframework |
| cpe:2.3:a:yiiframework:yiiframework:2.0.13:*:*:*:*:*:*:* | 2.0.13 | Vulnerable | Yiiframework |
| cpe:2.3:a:yiiframework:yiiframework:2.0.13.1:*:*:*:*:*:*:* | 2.0.13.1 | Vulnerable | Yiiframework |
- cpe:2.3:a:yiiframework:yiiframework:2.0.7:*:*:*:*:*:*:* Versions 2.0.7 Vulnerable ·Yiiframework
- cpe:2.3:a:yiiframework:yiiframework:2.0.8:*:*:*:*:*:*:* Versions 2.0.8 Vulnerable ·Yiiframework
- cpe:2.3:a:yiiframework:yiiframework:2.0.9:*:*:*:*:*:*:* Versions 2.0.9 Vulnerable ·Yiiframework
- cpe:2.3:a:yiiframework:yiiframework:2.0.10:*:*:*:*:*:*:* Versions 2.0.10 Vulnerable ·Yiiframework
- cpe:2.3:a:yiiframework:yiiframework:2.0.11:*:*:*:*:*:*:* Versions 2.0.11 Vulnerable ·Yiiframework
- cpe:2.3:a:yiiframework:yiiframework:2.0.11.1:*:*:*:*:*:*:* Versions 2.0.11.1 Vulnerable ·Yiiframework
- cpe:2.3:a:yiiframework:yiiframework:2.0.11.2:*:*:*:*:*:*:* Versions 2.0.11.2 Vulnerable ·Yiiframework
- cpe:2.3:a:yiiframework:yiiframework:2.0.12:*:*:*:*:*:*:* Versions 2.0.12 Vulnerable ·Yiiframework
- cpe:2.3:a:yiiframework:yiiframework:2.0.13:*:*:*:*:*:*:* Versions 2.0.13 Vulnerable ·Yiiframework
- cpe:2.3:a:yiiframework:yiiframework:2.0.13.1:*:*:*:*:*:*:* Versions 2.0.13.1 Vulnerable ·Yiiframework
Remediation
- Fix · GHSA-cwhm-272p-3wj9 yiisoft/yii2 (Packagist) Fixed in 2.0.14 Advisory →
- Fix · GHSA-cwhm-272p-3wj9 yiisoft/yii2-dev (Packagist) Fixed in 2.0.14 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-6009
- 2026-10-03 Alias added: GHSA-cwhm-272p-3wj9
References
Other 4
More Yiiframework vulnerabilities
- TI-2018-04378 In Yii Framework 2.x before 2.0.14, remote attackers could obtain potentially sensitive… CVSS 3.0HIGH 7.5
- TI-2014-03851 The CDetailView widget in Yii PHP Framework 1.1.14 allows remote attackers to execute… CVSS 2.0HIGH 7.5
- TI-2015-03005 Cross-site scripting (XSS) vulnerability in Yii Framework before 2.0.4 allows remote… CVSS 2.0MEDIUM 4.3
Sources
- CVE-2018-6009 · CVE Program
- CVE-2018-6009 · NVD
- FIRST EPSS
- GHSA-cwhm-272p-3wj9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences