Directory traversal vulnerability in Contao before 3.2.19, and 3.4.x before 3.4.4 allows…
Priority LOW 24CWE-22Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-22 and the CVSS impact.
Summary
Directory traversal vulnerability in Contao before 3.2.19, and 3.4.x before 3.4.4 allows remote authenticated "back end" users to view files outside their file mounts or the document root via unspecified vectors.
Why it matters now
EPSS 0.02099 81st percentileScored 2026-11-07
Fix Fixed contao/core (Packagist): 3.4.4, 3.2.19
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | contao/core (Packagist) | 3.4.0 to before 3.4.4 | 3.4.4 | Patch available | GHSA-4r6g-xhx7-fm36 |
| — | contao/core (Packagist) | 2.0.0 to before 3.2.19 | 3.2.19 | Patch available | GHSA-4r6g-xhx7-fm36 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- contao/core (Packagist) Vendor— Affected 3.4.0 to before 3.4.4 Fixed in 3.4.4 Patch available GHSA-4r6g-xhx7-fm36
- contao/core (Packagist) Vendor— Affected 2.0.0 to before 3.2.19 Fixed in 3.2.19 Patch available GHSA-4r6g-xhx7-fm36
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:contao:contao_cms:*:*:*:*:*:*:*:* | up to 3.2.18 | Vulnerable | contao |
| cpe:2.3:a:contao:contao_cms:3.4.0:*:*:*:*:*:*:* | 3.4.0 | Vulnerable | contao |
| cpe:2.3:a:contao:contao_cms:3.4.0:beta1:*:*:*:*:*:* | 3.4.0 beta1 | Vulnerable | contao |
| cpe:2.3:a:contao:contao_cms:3.4.1:*:*:*:*:*:*:* | 3.4.1 | Vulnerable | contao |
| cpe:2.3:a:contao:contao_cms:3.4.2:*:*:*:*:*:*:* | 3.4.2 | Vulnerable | contao |
| cpe:2.3:a:contao:contao_cms:3.4.3:*:*:*:*:*:*:* | 3.4.3 | Vulnerable | contao |
- cpe:2.3:a:contao:contao_cms:*:*:*:*:*:*:*:* Versions up to 3.2.18 Vulnerable ·contao
- cpe:2.3:a:contao:contao_cms:3.4.0:*:*:*:*:*:*:* Versions 3.4.0 Vulnerable ·contao
- cpe:2.3:a:contao:contao_cms:3.4.0:beta1:*:*:*:*:*:* Versions 3.4.0 beta1 Vulnerable ·contao
- cpe:2.3:a:contao:contao_cms:3.4.1:*:*:*:*:*:*:* Versions 3.4.1 Vulnerable ·contao
- cpe:2.3:a:contao:contao_cms:3.4.2:*:*:*:*:*:*:* Versions 3.4.2 Vulnerable ·contao
- cpe:2.3:a:contao:contao_cms:3.4.3:*:*:*:*:*:*:* Versions 3.4.3 Vulnerable ·contao
Remediation
- Fix · GHSA-4r6g-xhx7-fm36 contao/core (Packagist) Fixed in 3.4.4 Advisory →
- Fix · GHSA-4r6g-xhx7-fm36 contao/core (Packagist) Fixed in 3.2.19 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2015-0269
- 2026-10-03 Alias added: GHSA-4r6g-xhx7-fm36
References
Advisory 4
More Contao Cms vulnerabilities
- TI-2014-01453 Contao CMS through 3.2.4 has PHP Object Injection Vulnerabilities CVSS 3.1CRITICAL 9.8
- TI-2019-07939 Contao 4.7 allows Use of a Key Past its Expiration Date. CVSS 3.0CRITICAL 9.8
- TI-2019-07937 Contao before 3.5.39 and 4.x before 4.7.3 has a Weak Password Recovery Mechanism for a Forgotten Password. CVSS 3.0CRITICAL 9.8
- TI-2017-12170 Contao 3.0.0 to 3.5.30 and 4.0.0 to 4.4.7 contains an SQL injection vulnerability in the… CVSS 3.0CRITICAL 9.8
- TI-2017-08073 Contao before 3.5.28 and 4.x before 4.4.1 allows remote attackers to include and execute… CVSS 3.0HIGH 8.8
- TI-2019-07938 Contao 4.7 allows CSRF. CVSS 3.0HIGH 8.8
Sources
- CVE-2015-0269 · CVE Program
- CVE-2015-0269 · NVD
- FIRST EPSS
- GHSA-4r6g-xhx7-fm36 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences