Cross-site request forgery (CSRF) vulnerability in Zend/Validator/Csrf in Zend Framework…
Priority LOW 39CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.
Summary
Cross-site request forgery (CSRF) vulnerability in Zend/Validator/Csrf in Zend Framework 2.3.x before 2.3.6 via null or malformed token identifiers.
Why it matters now
EPSS 0.00656 51st percentileScored 2026-11-07
Fix Fixed zendframework/zendframework (Packagist): 2.3.6
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | zendframework/zendframework (Packagist) | 2.3.0 to before 2.3.6 | 2.3.6 | Patch available | GHSA-gwwq-54qp-9pgp |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- zendframework/zendframework (Packagist) Vendor— Affected 2.3.0 to before 2.3.6 Fixed in 2.3.6 Patch available GHSA-gwwq-54qp-9pgp
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:zend:zend_framework:2.3.0:*:*:*:*:*:*:* | 2.3.0 | Vulnerable | Zend |
| cpe:2.3:a:zend:zend_framework:2.3.1:*:*:*:*:*:*:* | 2.3.1 | Vulnerable | Zend |
| cpe:2.3:a:zend:zend_framework:2.3.2:*:*:*:*:*:*:* | 2.3.2 | Vulnerable | Zend |
| cpe:2.3:a:zend:zend_framework:2.3.3:*:*:*:*:*:*:* | 2.3.3 | Vulnerable | Zend |
| cpe:2.3:a:zend:zend_framework:2.3.4:*:*:*:*:*:*:* | 2.3.4 | Vulnerable | Zend |
| cpe:2.3:a:zend:zend_framework:2.3.5:*:*:*:*:*:*:* | 2.3.5 | Vulnerable | Zend |
- cpe:2.3:a:zend:zend_framework:2.3.0:*:*:*:*:*:*:* Versions 2.3.0 Vulnerable ·Zend
- cpe:2.3:a:zend:zend_framework:2.3.1:*:*:*:*:*:*:* Versions 2.3.1 Vulnerable ·Zend
- cpe:2.3:a:zend:zend_framework:2.3.2:*:*:*:*:*:*:* Versions 2.3.2 Vulnerable ·Zend
- cpe:2.3:a:zend:zend_framework:2.3.3:*:*:*:*:*:*:* Versions 2.3.3 Vulnerable ·Zend
- cpe:2.3:a:zend:zend_framework:2.3.4:*:*:*:*:*:*:* Versions 2.3.4 Vulnerable ·Zend
- cpe:2.3:a:zend:zend_framework:2.3.5:*:*:*:*:*:*:* Versions 2.3.5 Vulnerable ·Zend
Remediation
- Fix · GHSA-gwwq-54qp-9pgp zendframework/zendframework (Packagist) Fixed in 2.3.6 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2015-1786
- 2026-10-03 Alias added: GHSA-gwwq-54qp-9pgp
- 2026-10-12 EPSS moved to the 50th–90th percentile
References
Advisory 3
Other 5
- https://github.com/zendframework/zendframework/commit/213d2c490f55331ba4e5e3884bd81d13d1eb0aee
- https://framework.zend.com/security/advisory/ZF2015-03
- https://github.com/FriendsOfPHP/security-advisories/blob/master/zendframework/zendframework/CVE-2015-1786.yaml
- https://github.com/zendframework/zf-web/blob/f97fe5c3cf6c51df7502237c6342511802c8df22/module/Security/view/security/advisory/ZF2015-03.phtml
- https://github.com/zendframework/zf3-web/blob/5852ab5bfd47285e6b46f9e7b13250629b3e372e/data/advisories/ZF2015-03.md
More Zend Framework vulnerabilities
- TI-2021-02150 Laminas Project laminas-http before 2.14.2, and Zend Framework 3.0.0, has a… CVSS 3.1CRITICAL 9.8
- TI-2012-02894 Zend_XmlRpc in Zend Framework 1.x before 1.11.12 and 1.12.x before 1.12.0 does not… CVSS 3.1CRITICAL 9.1
- TI-2016-08119 The setFrom function in the Sendmail adapter in the zend-mail component before 2.4.11… CVSS 3.0CRITICAL 9.8
- TI-2020-17638 An issue found in Zend Framework v.3.1.3 and before allow a remote attacker to execute… CVSS 3.1CRITICAL 9.8
- TI-2016-04204 The (1) order and (2) group methods in Zend_Db_Select in the Zend Framework before… CVSS 3.0CRITICAL 9.8
- TI-2011-01711 SQL injection in zendframework;PHP zendframework CVSS 3.1CRITICAL 9.8
Sources
- CVE-2015-1786 · CVE Program
- CVE-2015-1786 · NVD
- FIRST EPSS
- GHSA-gwwq-54qp-9pgp · GitHub Advisory Database · CC BY 4.0
- CVE-2015-1786 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences