Multiple cross-site scripting (XSS) vulnerabilities in the administration pages in…
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Multiple cross-site scripting (XSS) vulnerabilities in the administration pages in Kallithea before 0.2.1 allow remote attackers to inject arbitrary web script or HTML via the (1) first name or (2) last name user details, or the (3) repository, (4) repository group, or (5) user group description.
Why it matters now
EPSS 0.00944 61st percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed Kallithea (PyPI): 0.2.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | Kallithea (PyPI) | before 0.2.1 | 0.2.1 | Patch available | GHSA-fh5c-7gmg-xmp6 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- Kallithea (PyPI) Vendor— Affected before 0.2.1 Fixed in 0.2.1 Patch available GHSA-fh5c-7gmg-xmp6
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:kallithea-scm:kallithea:0.1:*:*:*:*:*:*:* | 0.1 | Vulnerable | Kallithea-scm |
| cpe:2.3:a:kallithea-scm:kallithea:0.2:*:*:*:*:*:*:* | 0.2 | Vulnerable | Kallithea-scm |
- cpe:2.3:a:kallithea-scm:kallithea:0.1:*:*:*:*:*:*:* Versions 0.1 Vulnerable ·Kallithea-scm
- cpe:2.3:a:kallithea-scm:kallithea:0.2:*:*:*:*:*:*:* Versions 0.2 Vulnerable ·Kallithea-scm
Remediation
- Fix · GHSA-fh5c-7gmg-xmp6 Kallithea (PyPI) Fixed in 0.2.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2015-1864
- 2026-10-03 Alias added: GHSA-fh5c-7gmg-xmp6
References
Exploit 2
More Kallithea-scm Kallithea vulnerabilities
- TI-2016-03124 Routes in Kallithea before 0.3.2 allows remote attackers to bypass the CSRF protection by… CVSS 3.0HIGH 8.8
- TI-2015-00243 Cross-site request forgery (CSRF) vulnerability in Kallithea before 0.2. CVSS 3.0HIGH 8.8
- TI-2015-04441 CRLF injection vulnerability in Kallithea before 0.3 allows remote attackers to inject… CVSS 2.0MEDIUM 5.0
- TI-2015-00228 RhodeCode before 2.2.7 and Kallithea 0.1 allows remote authenticated users to obtain API… CVSS 2.0MEDIUM 4.0
Sources
- CVE-2015-1864 · CVE Program
- CVE-2015-1864 · NVD
- FIRST EPSS
- GHSA-fh5c-7gmg-xmp6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences