Routes in Kallithea before 0.3.2 allows remote attackers to bypass the CSRF protection by…
Priority LOW 39CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.
Summary
Routes in Kallithea before 0.3.2 allows remote attackers to bypass the CSRF protection by using the GET HTTP request method.
Why it matters now
EPSS 0.00592 48th percentileScored 2026-11-07
Fix Fixed kallithea (PyPI): 0.3.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | kallithea (PyPI) | before 0.3.2 | 0.3.2 | Patch available | GHSA-799h-qr84-pcrp |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- kallithea (PyPI) Vendor— Affected before 0.3.2 Fixed in 0.3.2 Patch available GHSA-799h-qr84-pcrp
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:kallithea-scm:kallithea:*:*:*:*:*:*:*:* | up to 0.3.1 | Vulnerable | Kallithea-scm |
- cpe:2.3:a:kallithea-scm:kallithea:*:*:*:*:*:*:*:* Versions up to 0.3.1 Vulnerable ·Kallithea-scm
Remediation
- Fix · GHSA-799h-qr84-pcrp kallithea (PyPI) Fixed in 0.3.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-3691
- 2026-10-03 Alias added: GHSA-799h-qr84-pcrp
References
More Kallithea-scm Kallithea vulnerabilities
- TI-2015-00243 Cross-site request forgery (CSRF) vulnerability in Kallithea before 0.2. CVSS 3.0HIGH 8.8
- TI-2015-04441 CRLF injection vulnerability in Kallithea before 0.3 allows remote attackers to inject… CVSS 2.0MEDIUM 5.0
- TI-2015-01674 Multiple cross-site scripting (XSS) vulnerabilities in the administration pages in… CVSS 3.0MEDIUM 5.4
- TI-2015-00228 RhodeCode before 2.2.7 and Kallithea 0.1 allows remote authenticated users to obtain API… CVSS 2.0MEDIUM 4.0
Sources
- CVE-2016-3691 · CVE Program
- CVE-2016-3691 · NVD
- FIRST EPSS
- GHSA-799h-qr84-pcrp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences