CRLF injection vulnerability in Kallithea before 0.3 allows remote attackers to inject…
Priority LOW 32CWE-93Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub.
Summary
CRLF injection vulnerability in Kallithea before 0.3 allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks via the came_from parameter to _admin/login.
Why it matters now
EPSS 0.06205 93rd percentileScored 2026-11-07
Public exploit Yes 4 exploit referencesTagged by the CNA and NVD
Fix Fixed kallithea (PyPI): 0.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | kallithea (PyPI) | before 0.3 | 0.3 | Patch available | GHSA-vfg9-phjp-9frw |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- kallithea (PyPI) Vendor— Affected before 0.3 Fixed in 0.3 Patch available GHSA-vfg9-phjp-9frw
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:kallithea-scm:kallithea:*:*:*:*:*:*:*:* | up to 0.2 | Vulnerable | Kallithea-scm |
- cpe:2.3:a:kallithea-scm:kallithea:*:*:*:*:*:*:*:* Versions up to 0.2 Vulnerable ·Kallithea-scm
Remediation
- Fix · GHSA-vfg9-phjp-9frw kallithea (PyPI) Fixed in 0.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2015-5285
- 2026-10-03 Alias added: GHSA-vfg9-phjp-9frw
References
Exploit 4
More Kallithea-scm Kallithea vulnerabilities
- TI-2016-03124 Routes in Kallithea before 0.3.2 allows remote attackers to bypass the CSRF protection by… CVSS 3.0HIGH 8.8
- TI-2015-00243 Cross-site request forgery (CSRF) vulnerability in Kallithea before 0.2. CVSS 3.0HIGH 8.8
- TI-2015-01674 Multiple cross-site scripting (XSS) vulnerabilities in the administration pages in… CVSS 3.0MEDIUM 5.4
- TI-2015-00228 RhodeCode before 2.2.7 and Kallithea 0.1 allows remote authenticated users to obtain API… CVSS 2.0MEDIUM 4.0
Sources
- CVE-2015-5285 · CVE Program
- CVE-2015-5285 · NVD
- FIRST EPSS
- GHSA-vfg9-phjp-9frw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences