Cross-site scripting in ikiwiki
Priority LOW 31CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in templates/openid-selector.tmpl in ikiwiki before 3.20150329 allows remote attackers to inject arbitrary web script or HTML via the openid_identifier parameter in a verify action to ikiwiki.cgi.
Why it matters now
EPSS 0.01688 77th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed ikiwiki (ikiwiki): 3.20150329
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ikiwiki | ikiwiki | before 3.20150329 | 3.20150329 | Patch available | CNA |
- ikiwiki Vendorikiwiki Affected before 3.20150329 Fixed in 3.20150329 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ikiwiki:ikiwiki:*:*:*:*:*:*:*:* | before 3.20150329 | Vulnerable | ikiwiki |
| cpe:2.3:o:fedoraproject:fedora:20:*:*:*:*:*:*:* | 20 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:21:*:*:*:*:*:*:* | 21 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:22:*:*:*:*:*:*:* | 22 | Vulnerable | Fedoraproject |
- cpe:2.3:a:ikiwiki:ikiwiki:*:*:*:*:*:*:*:* Versions before 3.20150329 Vulnerable ·ikiwiki
- cpe:2.3:o:fedoraproject:fedora:20:*:*:*:*:*:*:* Versions 20 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:21:*:*:*:*:*:*:* Versions 21 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:22:*:*:*:*:*:*:* Versions 22 Vulnerable ·Fedoraproject
Remediation
- Fix · CNA ikiwiki (ikiwiki) Fixed in 3.20150329
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2015-2793
- 2026-10-03 Alias added: GHSA-pc62-pw4x-v3r6
References
Patch 3
Advisory 4
More Ikiwiki vulnerabilities
- TI-2017-00331 Authentication bypass via repeated parameters CVSS 3.0CRITICAL 9.8
- TI-2011-01233 ikiwiki before 3.20110608 allows remote attackers to hijack root's tty and run symlink attacks. CVSS 3.1HIGH 8.2
- TI-2016-08112 ikiwiki 3.20161219 does not properly check if a revision changes the access permissions… CVSS 3.0HIGH 7.5
- TI-2019-06647 ikiwiki before 3.20170111.1 and 3.2018x and 3.2019x before 3.20190228 allows SSRF via the… CVSS 3.0HIGH 7.5
- TI-2008-00155 Plugin/passwordauth.pm (aka the passwordauth plugin) in ikiwiki 1.34 through 2.47 allows… CVSS 2.0MEDIUM 6.8
- TI-2016-07849 Editing restriction bypass for git revert CVSS 3.0MEDIUM 6.5
Sources
- CVE-2015-2793 · CVE Program
- CVE-2015-2793 · NVD
- FIRST EPSS
- GHSA-pc62-pw4x-v3r6 · GitHub Advisory Database · CC BY 4.0
- CVE-2015-2793 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences