Read the docs

ikiwiki

Records18All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical1CVSS 9.0–10.0
CVSS high3CVSS 7.0–8.9

Exploited now

ikiwiki records in CISA KEV

No ikiwiki vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

18 records

Priority MEDIUM 48

A flaw, similar to to CVE-2016-9646, exists in ikiwiki before 3.20170111, in the passwordauth plugin's use of CGI::FormBuilder, allowing an attacker to bypass authentication via repeated parameters.

CVSS 3.0CRITICAL 9.8 Network No auth No interaction EPSS 0.03276 Published 2018-04-13 Fixed in 3.20170111 CWE-287
Priority LOW 33

Plugin/passwordauth.pm (aka the passwordauth plugin) in ikiwiki 1.34 through 2.47 allows remote attackers to bypass authentication, and login to any account for which an OpenID identity is configured and a password is no…

CVSS 2.0MEDIUM 6.8 Network No auth Interaction — EPSS 0.01576 Published 2008-06-03 No fix listed CWE-264
TI-2016-07849 CVE-2016-9645 · GHSA-4xrj-353q-c3p7

Editing restriction bypass for git revert

Priority LOW 31

The fix for ikiwiki for CVE-2016-10026 was incomplete resulting in editing restriction bypass for git revert when using git versions older than 2.8.0.

CVSS 3.0MEDIUM 6.5 Network Low privileges No interaction EPSS 0.00912 Published 2018-04-10 No fix listed CWE-284
TI-2015-02467 CVE-2015-2793 · GHSA-pc62-pw4x-v3r6

Cross-site scripting in ikiwiki

Priority LOW 31

Cross-site scripting (XSS) vulnerability in templates/openid-selector.tmpl in ikiwiki before 3.20150329 allows remote attackers to inject arbitrary web script or HTML via the openid_identifier parameter in a verify actio…

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.01688 Published 2019-11-21 Fixed in 3.20150329 CWE-79
Priority LOW 26

ikiwiki before 3.20161229 incorrectly called the CGI::FormBuilder->field method (similar to the CGI->param API that led to Bugzilla's CVE-2014-1572), which can be abused to lead to commit metadata forgery.

CVSS 3.0MEDIUM 5.3 Network No auth No interaction EPSS 0.01138 Published 2018-04-13 Fixed in 3.20161229 CWE-287
Priority LOW 19

ikiwiki before 3.20110328 does not ascertain whether the htmlscrubber plugin is enabled during processing of the "meta stylesheet" directive, which allows remote authenticated users to conduct cross-site scripting (XSS)…

CVSS 2.0LOW 3.5 Network Low privileges Interaction — EPSS 0.0106 Published 2011-04-11 No fix listed CWE-79
Open these records in search →