Read the docs
TI-2017-00331 Aliases CVE-2017-0356GHSA-v4mw-26wf-pfx6

Authentication bypass via repeated parameters

Priority MEDIUM 48CWE-287Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-287.

Summary

A flaw, similar to to CVE-2016-9646, exists in ikiwiki before 3.20170111, in the passwordauth plugin's use of CGI::FormBuilder, allowing an attacker to bypass authentication via repeated parameters.

Why it matters now

EPSS 0.03276 88th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed ikiwiki (ikiwiki): 3.20170111

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
ikiwikiikiwikibefore 3.201701113.20170111Patch availableCNA
  • ikiwiki Vendorikiwiki Affected before 3.20170111 Fixed in 3.20170111 Patch available CNA

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:ikiwiki:ikiwiki:*:*:*:*:*:*:*:*before 3.20170111Vulnerableikiwiki
cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:*7.0VulnerableDebian
cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*8.0VulnerableDebian
  • cpe:2.3:a:ikiwiki:ikiwiki:*:*:*:*:*:*:*:* Versions before 3.20170111 Vulnerable ·ikiwiki
  • cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Debian
  • cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian

Remediation

  • Fix · CNA ikiwiki (ikiwiki) Fixed in 3.20170111

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Advisory ·

    ikiwiki — DSA-3760

    2 records Highest priority Priority MEDIUM 1 MEDIUM, 1 LOW

    Other records, highest priority first

    • TI-2016-07850 Commit metadata forgery via CGI::FormBuilder context-dependent APIsPriority LOW 26

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-0356
  2. 2026-10-03 Alias added: GHSA-v4mw-26wf-pfx6

References

  • TI-2011-01233 ikiwiki before 3.20110608 allows remote attackers to hijack root's tty and run symlink attacks. CVSS 3.1HIGH 8.2
  • TI-2016-08112 ikiwiki 3.20161219 does not properly check if a revision changes the access permissions… CVSS 3.0HIGH 7.5
  • TI-2019-06647 ikiwiki before 3.20170111.1 and 3.2018x and 3.2019x before 3.20190228 allows SSRF via the… CVSS 3.0HIGH 7.5
  • TI-2008-00155 Plugin/passwordauth.pm (aka the passwordauth plugin) in ikiwiki 1.34 through 2.47 allows… CVSS 2.0MEDIUM 6.8
  • TI-2016-07849 Editing restriction bypass for git revert CVSS 3.0MEDIUM 6.5
  • TI-2015-02467 Cross-site scripting in ikiwiki CVSS 3.1MEDIUM 6.1
See all 17 →

Sources