Injection in Zend Framework
Priority LOW 29CWE-74Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
CRLF injection vulnerability in Zend\Mail (Zend_Mail) in Zend Framework before 1.12.12, 2.x before 2.3.8, and 2.4.x before 2.4.1 allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks via CRLF sequences in the header of an email.
Why it matters now
EPSS 0.01009 63rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Zend Framework (Zend Technologies): 1.12.12, 2.3.8, 2.4.1zendframework/zend-http (Packagist): 2.3.8, 2.4.1, 1.12.12+2 more products
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Zend Technologies | Zend Framework | before 1.12.12; 2 to before 2.3.8; 2.4 to before 2.4.1 | 1.12.12, 2.3.8, 2.4.1 | Patch available | CNA |
| — | zendframework/zend-http (Packagist) | 2.0.0beta4 to before 2.3.8 | 2.3.8 | Patch available | GHSA-5957-5crx-79jx |
| — | zendframework/zend-http (Packagist) | 2.4.0rc1 to before 2.4.1 | 2.4.1 | Patch available | GHSA-5957-5crx-79jx |
| — | zendframework/zendframework (Packagist) | 2.0.0beta4 to before 2.3.8 | 2.3.8 | Patch available | GHSA-5957-5crx-79jx |
| — | zendframework/zendframework (Packagist) | 2.4.0rc1 to before 2.4.1 | 2.4.1 | Patch available | GHSA-5957-5crx-79jx |
| — | zendframework/zendframework1 (Packagist) | before 1.12.12 | 1.12.12 | Patch available | GHSA-5957-5crx-79jx |
| — | zendframework/zend-http (Packagist) | before 1.12.12 | 1.12.12 | Patch available | GHSA-5957-5crx-79jx |
- Zend Framework VendorZend Technologies Affected before 1.12.12; 2 to before 2.3.8; 2.4 to before 2.4.1 Fixed in 1.12.12, 2.3.8, 2.4.1 Patch available CNA
- zendframework/zend-http (Packagist) Vendor— Affected 2.0.0beta4 to before 2.3.8 Fixed in 2.3.8 Patch available GHSA-5957-5crx-79jx
- zendframework/zend-http (Packagist) Vendor— Affected 2.4.0rc1 to before 2.4.1 Fixed in 2.4.1 Patch available GHSA-5957-5crx-79jx
- zendframework/zendframework (Packagist) Vendor— Affected 2.0.0beta4 to before 2.3.8 Fixed in 2.3.8 Patch available GHSA-5957-5crx-79jx
- zendframework/zendframework (Packagist) Vendor— Affected 2.4.0rc1 to before 2.4.1 Fixed in 2.4.1 Patch available GHSA-5957-5crx-79jx
- zendframework/zendframework1 (Packagist) Vendor— Affected before 1.12.12 Fixed in 1.12.12 Patch available GHSA-5957-5crx-79jx
- zendframework/zend-http (Packagist) Vendor— Affected before 1.12.12 Fixed in 1.12.12 Patch available GHSA-5957-5crx-79jx
Remediation
- Fix · CNA Zend Framework (Zend Technologies) Fixed in 1.12.12, 2.3.8, 2.4.1
- Fix · GHSA-5957-5crx-79jx zendframework/zend-http (Packagist) Fixed in 2.3.8 Advisory →
- Fix · GHSA-5957-5crx-79jx zendframework/zend-http (Packagist) Fixed in 2.4.1 Advisory →
- Fix · GHSA-5957-5crx-79jx zendframework/zendframework (Packagist) Fixed in 2.3.8 Advisory →
- Fix · GHSA-5957-5crx-79jx zendframework/zendframework (Packagist) Fixed in 2.4.1 Advisory →
- Fix · GHSA-5957-5crx-79jx zendframework/zendframework1 (Packagist) Fixed in 1.12.12 Advisory →
- Fix · GHSA-5957-5crx-79jx zendframework/zend-http (Packagist) Fixed in 1.12.12 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2015-3154
- 2026-10-03 Alias added: GHSA-5957-5crx-79jx
References
Other 5
- https://framework.zend.com/security/advisory/ZF2015-04
- https://github.com/FriendsOfPHP/security-advisories/blob/master/zendframework/zend-http/CVE-2015-3154.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/zendframework/zendframework/CVE-2015-3154.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/zendframework/zendframework1/CVE-2015-3154.yaml
- https://github.com/zendframework/zendframework
More Zend Framework vulnerabilities
- TI-2021-02150 Laminas Project laminas-http before 2.14.2, and Zend Framework 3.0.0, has a… CVSS 3.1CRITICAL 9.8
- TI-2012-02894 Zend_XmlRpc in Zend Framework 1.x before 1.11.12 and 1.12.x before 1.12.0 does not… CVSS 3.1CRITICAL 9.1
- TI-2016-08119 The setFrom function in the Sendmail adapter in the zend-mail component before 2.4.11… CVSS 3.0CRITICAL 9.8
- TI-2020-17638 An issue found in Zend Framework v.3.1.3 and before allow a remote attacker to execute… CVSS 3.1CRITICAL 9.8
- TI-2016-04204 The (1) order and (2) group methods in Zend_Db_Select in the Zend Framework before… CVSS 3.0CRITICAL 9.8
- TI-2011-01711 SQL injection in zendframework;PHP zendframework CVSS 3.1CRITICAL 9.8
Sources
- CVE-2015-3154 · CVE Program
- CVE-2015-3154 · NVD
- FIRST EPSS
- GHSA-5957-5crx-79jx · GitHub Advisory Database · CC BY 4.0
- CVE-2015-3154 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences