Cross-site scripting (XSS) vulnerability in IPython 3.x before 3.2 allows remote…
Priority LOW 31CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in IPython 3.x before 3.2 allows remote attackers to inject arbitrary web script or HTML via vectors involving JSON error messages and the /api/contents path.
Why it matters now
EPSS 0.021 81st percentileScored 2026-11-07
Fix Fixed ipython (PyPI): 3.2.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | ipython (PyPI) | 3.0.0 to before 3.2.0 | 3.2.0 | Patch available | GHSA-q326-jhw3-699g |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- ipython (PyPI) Vendor— Affected 3.0.0 to before 3.2.0 Fixed in 3.2.0 Patch available GHSA-q326-jhw3-699g
Remediation
- Fix · GHSA-q326-jhw3-699g ipython (PyPI) Fixed in 3.2.0 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2015-4706
- 2026-10-03 Alias added: GHSA-q326-jhw3-699g
References
Patch 2
Advisory 5
More Ipython vulnerabilities
- TI-2022-06075 Execution with Unnecessary Privileges in ipython CVSS 3.1HIGH 8.8
- TI-2023-10316 set_term_title command injection in ipython CVSS 3.1HIGH 7.0
- TI-2015-04725 Cross-site request forgery in the REST API in IPython 2 and 3. CVSS 3.0HIGH 8.8
- TI-2015-03937 Cross-site scripting (XSS) vulnerability in IPython before 3.2 allows remote attackers to… CVSS 3.1MEDIUM 6.1
Sources
- CVE-2015-4706 · CVE Program
- CVE-2015-4706 · NVD
- FIRST EPSS
- GHSA-q326-jhw3-699g · GitHub Advisory Database · CC BY 4.0
- CVE-2015-4706 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences