Read the docs
TI-2023-10316 Aliases CVE-2023-24816GHSA-29gw-9793-fvw7

set_term_title command injection in ipython

Priority MEDIUM 64CWE-20Published · Updated

Key facts

Attack vector
Local
Privileges required
None
User interaction
Required
Attack complexity
High
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-78.

Summary

IPython (Interactive Python) is a command shell for interactive computing in multiple programming languages, originally developed for the Python programming language. Versions prior to 8.1.0 are subject to a command injection vulnerability with very specific prerequisites. This vulnerability requires that the function `IPython.utils.terminal.set_term_title` be called on Windows in a Python environment where ctypes is not available. The dependency on `ctypes` in `IPython.utils._process_win32` prevents the vulnerable code from ever being reached in the ipython binary. However, as a library that could be used by another tool `set_term_title` could be called and hence introduce a vulnerability. Should an attacker get untrusted input to an instance of this function they would be able to inject shell commands as current process and limited to the scope of the current process. Users of ipython as a library are advised to upgrade. Users unable to upgrade should ensure that any calls to the `IPython.utils.terminal.set_term_title` function are done with trusted or filtered input.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01306 70th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed ipython (ipython): 8.10ipython (PyPI): 8.10.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ipythonipythonbefore 8.108.10Patch availableCNA
—ipython (PyPI)before 8.10.08.10.0Patch availableGHSA-29gw-9793-fvw7
  • ipython Vendoripython Affected before 8.10 Fixed in 8.10 Patch available CNA
  • ipython (PyPI) Vendor— Affected before 8.10.0 Fixed in 8.10.0 Patch available GHSA-29gw-9793-fvw7

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:ipython:ipython:*:*:*:*:*:*:*:*before 8.10.0Vulnerableipython
cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:*not specified by NVDRunning onMicrosoft
  • cpe:2.3:a:ipython:ipython:*:*:*:*:*:*:*:* Versions before 8.10.0 Vulnerable ·ipython
  • cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Microsoft

Remediation

  • Fix · CNA ipython (ipython) Fixed in 8.10
  • Fix · GHSA-29gw-9793-fvw7 ipython (PyPI) Fixed in 8.10.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-24816
  2. 2026-10-03 Alias added: GHSA-29gw-9793-fvw7

References

  • TI-2022-06075 Execution with Unnecessary Privileges in ipython CVSS 3.1HIGH 8.8
  • TI-2015-04725 Cross-site request forgery in the REST API in IPython 2 and 3. CVSS 3.0HIGH 8.8
  • TI-2015-03937 Cross-site scripting (XSS) vulnerability in IPython before 3.2 allows remote attackers to… CVSS 3.1MEDIUM 6.1
  • TI-2015-03936 Cross-site scripting (XSS) vulnerability in IPython 3.x before 3.2 allows remote… CVSS 3.0MEDIUM 6.1

Sources