Execution with Unnecessary Privileges in ipython
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-250.
Summary
IPython (Interactive Python) is a command shell for interactive computing in multiple programming languages, originally developed for the Python programming language. Affected versions are subject to an arbitrary code execution vulnerability achieved by not properly managing cross user temporary files. This vulnerability allows one user to run code as another on the same machine. All users are advised to upgrade.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ipython | ipython | before 5.11; 6.0.0 to before 7.16.3; 7.17.0 to before 7.31.1; 8.0.0 to before 8.0.1 | 5.11, 7.16.3, 7.31.1, 8.0.1 | Patch available | CNA |
| — | ipython (PyPI) | before 5.11 | 5.11 | Patch available | GHSA-pq7m-3gw7-gq5x |
| — | ipython (PyPI) | 6.0.0 to before 7.16.3 | 7.16.3 | Patch available | GHSA-pq7m-3gw7-gq5x |
| — | ipython (PyPI) | 7.17.0 to before 7.31.1 | 7.31.1 | Patch available | GHSA-pq7m-3gw7-gq5x |
| — | ipython (PyPI) | 8.0.0 to before 8.0.1 | 8.0.1 | Patch available | GHSA-pq7m-3gw7-gq5x |
- ipython Vendoripython Affected before 5.11; 6.0.0 to before 7.16.3; 7.17.0 to before 7.31.1; 8.0.0 to before 8.0.1 Fixed in 5.11, 7.16.3, 7.31.1, 8.0.1 Patch available CNA
- ipython (PyPI) Vendor— Affected before 5.11 Fixed in 5.11 Patch available GHSA-pq7m-3gw7-gq5x
- ipython (PyPI) Vendor— Affected 6.0.0 to before 7.16.3 Fixed in 7.16.3 Patch available GHSA-pq7m-3gw7-gq5x
- ipython (PyPI) Vendor— Affected 7.17.0 to before 7.31.1 Fixed in 7.31.1 Patch available GHSA-pq7m-3gw7-gq5x
- ipython (PyPI) Vendor— Affected 8.0.0 to before 8.0.1 Fixed in 8.0.1 Patch available GHSA-pq7m-3gw7-gq5x
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ipython:ipython:*:*:*:*:*:*:*:* | up to 5.10.0; 6.0.0 to before 7.16.3; 7.17.0 to before 7.31.1; 8.0.0 to before 8.0.1 | Vulnerable | ipython |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* | 11.0 | Vulnerable | Debian |
| cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:* | 34 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* | 35 | Vulnerable | Fedoraproject |
- cpe:2.3:a:ipython:ipython:*:*:*:*:*:*:*:* Versions up to 5.10.0; 6.0.0 to before 7.16.3; 7.17.0 to before 7.31.1; 8.0.0 to before 8.0.1 Vulnerable ·ipython
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* Versions 11.0 Vulnerable ·Debian
- cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:* Versions 34 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* Versions 35 Vulnerable ·Fedoraproject
Remediation
- Fix · CNA ipython (ipython) Fixed in 5.11, 7.16.3, 7.31.1, 8.0.1
- Fix · GHSA-pq7m-3gw7-gq5x ipython (PyPI) Fixed in 5.11 Advisory →
- Fix · GHSA-pq7m-3gw7-gq5x ipython (PyPI) Fixed in 7.16.3 Advisory →
- Fix · GHSA-pq7m-3gw7-gq5x ipython (PyPI) Fixed in 7.31.1 Advisory →
- Fix · GHSA-pq7m-3gw7-gq5x ipython (PyPI) Fixed in 8.0.1 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2022-21699
- 2026-10-03 Alias added: GHSA-pq7m-3gw7-gq5x
- 2026-10-14 EPSS moved to the 50th–90th percentile
References
Advisory 5
Other 7
- https://github.com/ipython/ipython/commit/5fa1e409d2dc126c456510c16ece18e08b524e5b
- https://github.com/ipython/ipython/commit/67ca2b3aa9039438e6f80e3fccca556f26100b4d
- https://github.com/ipython/ipython/commit/a06ca837273271b4acb82c29be97c0b6d12a30ea
- https://github.com/ipython/ipython
- https://github.com/pypa/advisory-database/tree/main/vulns/ipython/PYSEC-2022-12.yaml
- https://lists.fedoraproject.org/archives/list/[email protected]/message/CRQRTWHYXMLDJ572VGVUZMUPEOTPM3KB
- https://lists.fedoraproject.org/archives/list/[email protected]/message/DZ7LVZBB4D7KVSFNEQUBEHFO3JW6D2ZK
More Ipython vulnerabilities
- TI-2023-10316 set_term_title command injection in ipython CVSS 3.1HIGH 7.0
- TI-2015-04725 Cross-site request forgery in the REST API in IPython 2 and 3. CVSS 3.0HIGH 8.8
- TI-2015-03937 Cross-site scripting (XSS) vulnerability in IPython before 3.2 allows remote attackers to… CVSS 3.1MEDIUM 6.1
- TI-2015-03936 Cross-site scripting (XSS) vulnerability in IPython 3.x before 3.2 allows remote… CVSS 3.0MEDIUM 6.1
Sources
- CVE-2022-21699 · CVE Program
- CVE-2022-21699 · NVD
- FIRST EPSS
- GHSA-pq7m-3gw7-gq5x · GitHub Advisory Database · CC BY 4.0
- CVE-2022-21699 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences