Cross-site scripting (XSS) vulnerability in IPython before 3.2 allows remote attackers to…
Priority LOW 32CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in IPython before 3.2 allows remote attackers to inject arbitrary web script or HTML via vectors involving JSON error messages and the /api/notebooks path.
Why it matters now
EPSS 0.02274 83rd percentileScored 2026-11-07
Fix Fixed ipython (PyPI): 3.2.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | ipython (PyPI) | before 3.2.0 | 3.2.0 | Patch available | GHSA-66gw-5xpf-gfp5 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- ipython (PyPI) Vendor— Affected before 3.2.0 Fixed in 3.2.0 Patch available GHSA-66gw-5xpf-gfp5
Remediation
- Fix · GHSA-66gw-5xpf-gfp5 ipython (PyPI) Fixed in 3.2.0 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2015-4707
- 2026-10-03 Alias added: GHSA-66gw-5xpf-gfp5
References
Patch 2
Advisory 5
More Ipython vulnerabilities
- TI-2022-06075 Execution with Unnecessary Privileges in ipython CVSS 3.1HIGH 8.8
- TI-2023-10316 set_term_title command injection in ipython CVSS 3.1HIGH 7.0
- TI-2015-04725 Cross-site request forgery in the REST API in IPython 2 and 3. CVSS 3.0HIGH 8.8
- TI-2015-03936 Cross-site scripting (XSS) vulnerability in IPython 3.x before 3.2 allows remote… CVSS 3.0MEDIUM 6.1
Sources
- CVE-2015-4707 · CVE Program
- CVE-2015-4707 · NVD
- FIRST EPSS
- GHSA-66gw-5xpf-gfp5 · GitHub Advisory Database · CC BY 4.0
- CVE-2015-4707 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences