Zend Framework before 2.4.9, zend-framework/zend-crypt 2.4.x before 2.4.9, and 2.5.x…
Priority LOW 36CWE-320Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
Zend Framework before 2.4.9, zend-framework/zend-crypt 2.4.x before 2.4.9, and 2.5.x before 2.5.2 allows remote attackers to recover the RSA private key.
Why it matters now
EPSS 0.01356 71st percentileScored 2026-11-07
Fix Fixed zendframework/zendframework (Packagist): 2.5.2, 2.4.9zendframework/zend-crypt (Packagist): 2.4.9, 2.5.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | zendframework/zendframework (Packagist) | 2.5.0 to before 2.5.2 | 2.5.2 | Patch available | GHSA-pm9m-w23q-5967 |
| — | zendframework/zend-crypt (Packagist) | 2.0.0 to before 2.4.9 | 2.4.9 | Patch available | GHSA-pm9m-w23q-5967 |
| — | zendframework/zend-crypt (Packagist) | 2.5.0 to before 2.5.2 | 2.5.2 | Patch available | GHSA-pm9m-w23q-5967 |
| — | zendframework/zendframework (Packagist) | 2.0.0 to before 2.4.9 | 2.4.9 | Patch available | GHSA-pm9m-w23q-5967 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- zendframework/zendframework (Packagist) Vendor— Affected 2.5.0 to before 2.5.2 Fixed in 2.5.2 Patch available GHSA-pm9m-w23q-5967
- zendframework/zend-crypt (Packagist) Vendor— Affected 2.0.0 to before 2.4.9 Fixed in 2.4.9 Patch available GHSA-pm9m-w23q-5967
- zendframework/zend-crypt (Packagist) Vendor— Affected 2.5.0 to before 2.5.2 Fixed in 2.5.2 Patch available GHSA-pm9m-w23q-5967
- zendframework/zendframework (Packagist) Vendor— Affected 2.0.0 to before 2.4.9 Fixed in 2.4.9 Patch available GHSA-pm9m-w23q-5967
CPE configurations NVD · 11
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:zend:zend_framework:2.4.0:*:*:*:*:*:*:* | 2.4.0 | Vulnerable | Zend |
| cpe:2.3:a:zend:zend_framework:2.4.1:*:*:*:*:*:*:* | 2.4.1 | Vulnerable | Zend |
| cpe:2.3:a:zend:zend_framework:2.4.2:*:*:*:*:*:*:* | 2.4.2 | Vulnerable | Zend |
| cpe:2.3:a:zend:zend_framework:2.4.3:*:*:*:*:*:*:* | 2.4.3 | Vulnerable | Zend |
| cpe:2.3:a:zend:zend_framework:2.4.4:*:*:*:*:*:*:* | 2.4.4 | Vulnerable | Zend |
| cpe:2.3:a:zend:zend_framework:2.4.5:*:*:*:*:*:*:* | 2.4.5 | Vulnerable | Zend |
| cpe:2.3:a:zend:zend_framework:2.4.6:*:*:*:*:*:*:* | 2.4.6 | Vulnerable | Zend |
| cpe:2.3:a:zend:zend_framework:2.4.7:*:*:*:*:*:*:* | 2.4.7 | Vulnerable | Zend |
| cpe:2.3:a:zend:zend_framework:2.4.8:*:*:*:*:*:*:* | 2.4.8 | Vulnerable | Zend |
| cpe:2.3:a:zend:zend_framework:2.5.0:*:*:*:*:*:*:* | 2.5.0 | Vulnerable | Zend |
- cpe:2.3:a:zend:zend_framework:2.4.0:*:*:*:*:*:*:* Versions 2.4.0 Vulnerable ·Zend
- cpe:2.3:a:zend:zend_framework:2.4.1:*:*:*:*:*:*:* Versions 2.4.1 Vulnerable ·Zend
- cpe:2.3:a:zend:zend_framework:2.4.2:*:*:*:*:*:*:* Versions 2.4.2 Vulnerable ·Zend
- cpe:2.3:a:zend:zend_framework:2.4.3:*:*:*:*:*:*:* Versions 2.4.3 Vulnerable ·Zend
- cpe:2.3:a:zend:zend_framework:2.4.4:*:*:*:*:*:*:* Versions 2.4.4 Vulnerable ·Zend
- cpe:2.3:a:zend:zend_framework:2.4.5:*:*:*:*:*:*:* Versions 2.4.5 Vulnerable ·Zend
- cpe:2.3:a:zend:zend_framework:2.4.6:*:*:*:*:*:*:* Versions 2.4.6 Vulnerable ·Zend
- cpe:2.3:a:zend:zend_framework:2.4.7:*:*:*:*:*:*:* Versions 2.4.7 Vulnerable ·Zend
- cpe:2.3:a:zend:zend_framework:2.4.8:*:*:*:*:*:*:* Versions 2.4.8 Vulnerable ·Zend
- cpe:2.3:a:zend:zend_framework:2.5.0:*:*:*:*:*:*:* Versions 2.5.0 Vulnerable ·Zend
Remediation
- Fix · GHSA-pm9m-w23q-5967 zendframework/zendframework (Packagist) Fixed in 2.5.2 Advisory →
- Fix · GHSA-pm9m-w23q-5967 zendframework/zend-crypt (Packagist) Fixed in 2.4.9 Advisory →
- Fix · GHSA-pm9m-w23q-5967 zendframework/zend-crypt (Packagist) Fixed in 2.5.2 Advisory →
- Fix · GHSA-pm9m-w23q-5967 zendframework/zendframework (Packagist) Fixed in 2.4.9 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2015-7503
- 2026-10-03 Alias added: GHSA-pm9m-w23q-5967
References
Advisory 3
More Zend Framework vulnerabilities
- TI-2021-02150 Laminas Project laminas-http before 2.14.2, and Zend Framework 3.0.0, has a… CVSS 3.1CRITICAL 9.8
- TI-2012-02894 Zend_XmlRpc in Zend Framework 1.x before 1.11.12 and 1.12.x before 1.12.0 does not… CVSS 3.1CRITICAL 9.1
- TI-2016-08119 The setFrom function in the Sendmail adapter in the zend-mail component before 2.4.11… CVSS 3.0CRITICAL 9.8
- TI-2020-17638 An issue found in Zend Framework v.3.1.3 and before allow a remote attacker to execute… CVSS 3.1CRITICAL 9.8
- TI-2016-04204 The (1) order and (2) group methods in Zend_Db_Select in the Zend Framework before… CVSS 3.0CRITICAL 9.8
- TI-2011-01711 SQL injection in zendframework;PHP zendframework CVSS 3.1CRITICAL 9.8
Sources
- CVE-2015-7503 · CVE Program
- CVE-2015-7503 · NVD
- FIRST EPSS
- GHSA-pm9m-w23q-5967 · GitHub Advisory Database · CC BY 4.0
- CVE-2015-7503 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences