The Script Security plugin before 1.18.1 in Jenkins might allow remote attackers to…
Priority LOW 36CWE-254Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.
Summary
The Script Security plugin before 1.18.1 in Jenkins might allow remote attackers to bypass a Groovy sandbox protection mechanism via a plugin that performs (1) direct field access or (2) get/set array operations.
Why it matters now
EPSS 0.01769 78th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:script-security (Maven): 1.18.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:script-security (Maven) | before 1.18.1 | 1.18.1 | Patch available | GHSA-xgjx-96v4-mqxx |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:script-security (Maven) Vendor— Affected before 1.18.1 Fixed in 1.18.1 Patch available GHSA-xgjx-96v4-mqxx
CPE configurations NVD · 19
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:jenkins:script_security:1.0:*:*:*:*:jenkins:*:* | 1.0 | Vulnerable | Jenkins |
| cpe:2.3:a:jenkins:script_security:1.1:*:*:*:*:jenkins:*:* | 1.1 | Vulnerable | Jenkins |
| cpe:2.3:a:jenkins:script_security:1.2:*:*:*:*:jenkins:*:* | 1.2 | Vulnerable | Jenkins |
| cpe:2.3:a:jenkins:script_security:1.3:*:*:*:*:jenkins:*:* | 1.3 | Vulnerable | Jenkins |
| cpe:2.3:a:jenkins:script_security:1.4:*:*:*:*:jenkins:*:* | 1.4 | Vulnerable | Jenkins |
| cpe:2.3:a:jenkins:script_security:1.5:*:*:*:*:jenkins:*:* | 1.5 | Vulnerable | Jenkins |
| cpe:2.3:a:jenkins:script_security:1.6:*:*:*:*:jenkins:*:* | 1.6 | Vulnerable | Jenkins |
| cpe:2.3:a:jenkins:script_security:1.7:*:*:*:*:jenkins:*:* | 1.7 | Vulnerable | Jenkins |
| cpe:2.3:a:jenkins:script_security:1.8:*:*:*:*:jenkins:*:* | 1.8 | Vulnerable | Jenkins |
| cpe:2.3:a:jenkins:script_security:1.9:*:*:*:*:jenkins:*:* | 1.9 | Vulnerable | Jenkins |
- cpe:2.3:a:jenkins:script_security:1.0:*:*:*:*:jenkins:*:* Versions 1.0 Vulnerable ·Jenkins
- cpe:2.3:a:jenkins:script_security:1.1:*:*:*:*:jenkins:*:* Versions 1.1 Vulnerable ·Jenkins
- cpe:2.3:a:jenkins:script_security:1.2:*:*:*:*:jenkins:*:* Versions 1.2 Vulnerable ·Jenkins
- cpe:2.3:a:jenkins:script_security:1.3:*:*:*:*:jenkins:*:* Versions 1.3 Vulnerable ·Jenkins
- cpe:2.3:a:jenkins:script_security:1.4:*:*:*:*:jenkins:*:* Versions 1.4 Vulnerable ·Jenkins
- cpe:2.3:a:jenkins:script_security:1.5:*:*:*:*:jenkins:*:* Versions 1.5 Vulnerable ·Jenkins
- cpe:2.3:a:jenkins:script_security:1.6:*:*:*:*:jenkins:*:* Versions 1.6 Vulnerable ·Jenkins
- cpe:2.3:a:jenkins:script_security:1.7:*:*:*:*:jenkins:*:* Versions 1.7 Vulnerable ·Jenkins
- cpe:2.3:a:jenkins:script_security:1.8:*:*:*:*:jenkins:*:* Versions 1.8 Vulnerable ·Jenkins
- cpe:2.3:a:jenkins:script_security:1.9:*:*:*:*:jenkins:*:* Versions 1.9 Vulnerable ·Jenkins
Show 9 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:jenkins:script_security:1.10:*:*:*:*:jenkins:*:* | 1.10 | Vulnerable | Jenkins |
| cpe:2.3:a:jenkins:script_security:1.11:*:*:*:*:jenkins:*:* | 1.11 | Vulnerable | Jenkins |
| cpe:2.3:a:jenkins:script_security:1.12:*:*:*:*:jenkins:*:* | 1.12 | Vulnerable | Jenkins |
| cpe:2.3:a:jenkins:script_security:1.13:*:*:*:*:jenkins:*:* | 1.13 | Vulnerable | Jenkins |
| cpe:2.3:a:jenkins:script_security:1.14:*:*:*:*:jenkins:*:* | 1.14 | Vulnerable | Jenkins |
| cpe:2.3:a:jenkins:script_security:1.15:*:*:*:*:jenkins:*:* | 1.15 | Vulnerable | Jenkins |
| cpe:2.3:a:jenkins:script_security:1.16:*:*:*:*:jenkins:*:* | 1.16 | Vulnerable | Jenkins |
| cpe:2.3:a:jenkins:script_security:1.17:*:*:*:*:jenkins:*:* | 1.17 | Vulnerable | Jenkins |
| cpe:2.3:a:jenkins:script_security:1.18:*:*:*:*:jenkins:*:* | 1.18 | Vulnerable | Jenkins |
- cpe:2.3:a:jenkins:script_security:1.10:*:*:*:*:jenkins:*:* Versions 1.10 Vulnerable ·Jenkins
- cpe:2.3:a:jenkins:script_security:1.11:*:*:*:*:jenkins:*:* Versions 1.11 Vulnerable ·Jenkins
- cpe:2.3:a:jenkins:script_security:1.12:*:*:*:*:jenkins:*:* Versions 1.12 Vulnerable ·Jenkins
- cpe:2.3:a:jenkins:script_security:1.13:*:*:*:*:jenkins:*:* Versions 1.13 Vulnerable ·Jenkins
- cpe:2.3:a:jenkins:script_security:1.14:*:*:*:*:jenkins:*:* Versions 1.14 Vulnerable ·Jenkins
- cpe:2.3:a:jenkins:script_security:1.15:*:*:*:*:jenkins:*:* Versions 1.15 Vulnerable ·Jenkins
- cpe:2.3:a:jenkins:script_security:1.16:*:*:*:*:jenkins:*:* Versions 1.16 Vulnerable ·Jenkins
- cpe:2.3:a:jenkins:script_security:1.17:*:*:*:*:jenkins:*:* Versions 1.17 Vulnerable ·Jenkins
- cpe:2.3:a:jenkins:script_security:1.18:*:*:*:*:jenkins:*:* Versions 1.18 Vulnerable ·Jenkins
Remediation
- Fix · GHSA-xgjx-96v4-mqxx org.jenkins-ci.plugins:script-security (Maven) Fixed in 1.18.1 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 2 products
- Red Hat OpenShift Enterprise 2
- Red Hat OpenShift Enterprise 3
Timeline
- 2026-10-02 Threatist record created from CVE-2016-3102
- 2026-10-03 Alias added: GHSA-xgjx-96v4-mqxx
References
More Jenkins Script Security vulnerabilities
- TI-2019-15874 Protection mechanism failure in Jenkins Script Security Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2019-15845 Protection mechanism failure in Jenkins Script Security Plugin CVSS 3.1HIGH 8.8
- TI-2024-22597 Protection mechanism failure in Jenkins Script Security Plugin CVSS 3.1CRITICAL 9.8
- TI-2019-15850 Protection mechanism failure in Jenkins Script Security Plugin CVSS 3.1HIGH 8.8
- TI-2019-15885 A sandbox bypass vulnerability in Jenkins Script Security Plugin 1.55 and earlier allows… CVSS 3.1CRITICAL 9.8
- TI-2019-07740 Code injection in Jenkins Script Security Plugin CVSS 3.1CRITICAL 9.9
Sources
- CVE-2016-3102 · CVE Program
- CVE-2016-3102 · NVD
- FIRST EPSS
- GHSA-xgjx-96v4-mqxx · GitHub Advisory Database · CC BY 4.0
- CVE-2016-3102 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences